[SOLVED] Cannot attach a Z-wave controller

  • Platform information:
    • OS: Ubuntu
    • openHAB version: 2.4

Soo…I had a Z-wave controller and a few switches installed, not controlling anything yet just playing with everything to learn OpenHAB nuances. I had some switch duplication showing up in the Control page of Paper UI so I decided to just delete the switch things and try over. But I couldn’t re-add the switches, I couldn’t discover them. So I removed the controller, and now I can’t see it. So I removed the Z-wave binding, re-installed, still no love. Very confused at this point. I know the computer can see the USB Z-wave controller, I can see it on one of the ports. What’s going on?

what do you mean by “switches”? Physical Z-Wave remote nodes or Virtual openHAB2 Items?
Which ZW Controller are you using? Which ZW nodes are you using?

Did you try to discover your Z-Wave nodes after you re-installed the binding? (which binding: Z-Wave or Z-Way?)

You should provide some additional info/screenshots to make the situation more clear. Check this also: How to ask a good question / Help Us Help You

why did you delete all of this (when you created this thread):

* Platform information:
  * Hardware: _CPUArchitecture/RAM/storage_
  * OS: _what OS is used and which version_
  * Java Runtime Environment: _which java platform is used and what version_
  * openHAB version:
* Issue of the topic: please be detailed explaining your issue
* Please post configurations (if applicable):
  * Items configuration related to the issue
  * Sitemap configuration related to the issue 
  * Rules code related to the issue
  * Services configuration related to the issue
* If logs where generated please post these here using code fences:

? :slight_smile:

I included the system information I thought would be relevant, but I can certainly include it all for reference:
Hardware: Intel Q9650 on Dell 0G261D motherboard
OS: Ubuntu 18.04.1 LTS
JRE: OpenJDK 1.8.0_192
OpenHAB 2.4
Issue: Cannot connect to a Aeotec Gen5 Z-stick

There really aren’t any screen shots I could include that would show anything. I will add that when I uninstall and reinstall the Z-way binding, I can see that action in the logs. And on the Configuration > Bindings page in Paper UI I can see the Z-wave binding (I also have Astro Binding, Network Binding, and NTP Binding installed, and they’re working properly).
By switches I mean a Vision in-wall z-wave 2-channel micro switch. It and the z-wave gateway were previously connected to OpenHAB and worked properly. My initial foray into a “fix” was because on the Paper UI Control screen, each channel of the Vision switch was showing multiple “switch buttons,” and with different names. So I figured I must have configured the switches in multiple places when I first installed it. In an attempt to clear that issue, I disconnected the Vision z-wave switch and attempted to re-connect to it. That’s when this all started.
If I display the system information I can see the USB port and the Z-wave gateway, so the computer can see the device. I’m guessing there is some kind of conflict within how OpenHAB manages devices, but that’s just my guess.
So here’s something new this morning: I removed the Z-way binding and re-installed, to show the log entry. The entry "Uninstalled ‘openhab-binding-zway’ " shows, but there is no log entry when I re-install it. But I can see it in Paper UI when I select the Inbox:

Maybe you mixed it up? You have to install the z-wave binding. But in your screenshot there is shown the z-way binding.

For the love of Pete…
I didn’t even realize the different, and hadn’t heard of z-way before. After installing the correct binding I had the controller link right up.
I still can’t connect my Vision micro switch. But I have only one switch and it could be I have a bad one. Everything else SEEMS to be working. I probably need another z-wave device to try before I dismiss the setup.

1 Like


Very good. :slightly_smiling_face: Could you please mark this topic as solved? Thanks.