[SOLVED] Cannot Auto Discover Z-wave devices

Hardware: Intel Q9650 on Dell 0G261D motherboard
OS: Ubuntu 18.04.1 LTS
JRE: OpenJDK 1.8.0_192
OpenHAB 2.4

I’ve had an up and running openHAB system but had to replace my z-wave USB antenna (Aeotec Z-stick Gen 5). This was my original (which had the USB plug broken off by an errant child) and replaced with the same device. It is installed and shows as online, but I cannot auto discover any devices, no matter the distance, using either paperUI or Habmin.
The port is correct (/dev/ttyACM0 and the device is online), it is set as the Master, and I’ve tried every Inclusion Mode setting. I have a trusty Leviton wall switch 1 foot from the gateway and no amount of button pushing on it makes a difference.
Any thoughts?

Sounds like you’ll need to perform a reset on each of your zwave devices if you are not able to exclude them from the controller.

They are still paired to your previous z stick and can only be paired to one controller at a time.

1 Like

That worked on my Leviton switch. Looks like I have a lot of work in front of me, sigh…

Instead of a reset use the new controller to exclude a device and then include if that is easier. The zwave network exists on the controller but a controller can trigger an exclusion on devices that are not part of their network.
There seem to be very few ways to backup the network information from a controller.

The new controller likely has a different ID in OH which meant your Items likely need their channel linkage changed.

1 Like

Excluding on the new controller didn’t work; I can’t see the devices to exclude them.
I started making my way through my z-wave devices to pair them to the new controller. A few are working but I’m struggling with some others in that I can’t seem to do a successful factory reset on them.
I had several Nutone outlets that I could not factory reset. They are now obsolete and the manual is poor, I was going to chalk those up to a poor design. But I have an Aeotec recessed door sensor Gen5 that I’m struggling with as well. I need to hold the button in for 20 seconds. The indicator lamp reacts as the manual suggests it should but I still can’t pair it. I’m wondering if I’m missing something else?

If you cannot factory reset try excluding them first. Any controller should be able to exclude a device. It does not need to be the controller of the joined network.

Thanks, Bruce. You’d mentioned this before and I still didn’t understand it, but it prompted me to search again. I found this explanation and it brought it all together:


1 Like

If you ever need to enable debug logging, this viewer can be useful.