[SOLVED]Cannot create thing. No binding found that supports creating a thing of type

Tags: #<Tag:0x00007f2fb5defe40>

Hi,
after i finally managed to change my code from 2.4 to 2.5 and app.bndrun doesn’t show any dependencies for my binding anymore, i have new problem:
Unfortunately, the things for my new binding can no longer be initialized or registered correctly. With paper-ui the thing will be created but not processed.
he following error message appears:

WARN o.e.s.c.t.internal.ThingRegistryImpl:259 - Cannot create thing. No binding found that supports creating a thing of type 'openwms:tcpbridge'.

and

ERROR o.e.s.i.r.c.i.thing.ThingResource:447 - Exception during HTTP PUT request for update config at 'things/openwms:tcpbridge:88e2f7b9/config'
java.lang.IllegalStateException: Thing with UID openwms:tcpbridge:88e2f7b9 has no handler attached.
	at org.eclipse.smarthome.core.thing.internal.ThingRegistryImpl.updateConfiguration(ThingRegistryImpl.java:93)
	at org.eclipse.smarthome.io.rest.core.internal.thing.ThingResource.updateConfiguration(ThingResource.java:438)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)

In the old development environment the ThingHandlerFactory (OSGI-INF) had to be created.
Is there such a way also neccessary in the new development environment?

I would be very happy about a hint for troubleshooting.
Thanks in advance
rainer

For code nothing changed between 2.4 and 2.5 (nothing structural). You still need ThingHandlerFactory. So I’m not sure how you came to the conclusion you don’t need it anymore? Did you have OSGI-INF xml files that you removed (we now use annotations) Can you point me to your code so I can give direct feedback.

@hilbrand
Yes, I had OSGI-INF xml files which I removed.

f.e. OpenWMSHandlerFactory.xml:

"<?xml version="1.0" encoding="UTF-8"?>
<scr:component xmlns:scr="http://www.osgi.org/xmlns/scr/v1.1.0" immediate="true" name="org.openhab.binding.openwms.internal.OpenWMSHandlerFactory">
	<implementation class="org.openhab.binding.openwms.internal.OpenWMSHandlerFactory"/>
	<service>
		<provide interface="org.eclipse.smarthome.core.thing.binding.ThingHandlerFactory"/>
	</service>
</scr:component>"

My code could be found here: https://github.com/zeezee300/openwms

I would really appreciate it if you could give me a hint on how to solve this problem or where to find a documentary about the annotations mentioned.

Many thanks in advance.
rainer

Here is the documentation about the ThingHandlerFactory. In the example code you can see the annotation on the class:

You also have a discovery bound to a bridge. The best way to register that can been seen in the following commit:

1 Like

@hilbrand
Yeah, that’s how I was hoping for good support.:+1:
I adapted my code accordingly and now it works as desired.

Many thanks for the quick help. :grinning: