[SOLVED] Cannot get connection to Milight iBox2

milight
binding
Tags: #<Tag:0x00007fe057305298> #<Tag:0x00007fe057305108>

(Thowa) #1

Hi All,

I’m pretty new to openHAB2. Today I heared of it for the first time.
It looks really interesting and promising, so I decided to give openHAB2 a try.

I’m using openHab on my Laptop currently.

  • Milight addon is installed .
  • Inbox is empty. clicking “+” shows “Milight Binding”.
  • clicking on “Milight Binding” starts a search for things but shortly comes up with “manually add thing”

I added a thing myself using the IP Address I have taken from the web interface and entered the port (8899) as well as the MAC Address of the iBox2.
Under Configuration -> Things I see my iBox2, but the status is “offline - Configuration pending SESSION_WAIT_FOR_BRIDGE”
Any help is very much appreciated.

Thorsten


(Mike Major) #2

Hi

I think the port needs to be 5987 for iBox2


(Thowa) #3

I’ve tried 5987 (although the WebServer on the iBox2 shows 8899 as Port ID
) also without success.

Here is the configuration file:

{ 
  "milight:bridgeV6:575b7684": {
    "class": "org.eclipse.smarthome.core.thing.internal.BridgeImpl",
    "value": {
      "label": "iBox2", 
      "channels": [],
      "configuration": { 
        "properties": {
          "REFRESH_IN_SEC": 5,
          "REPEAT": 1,
          "WAIT_BETWEEN_COMMANDS": 100,
          "ID": "F0FE6B72C135",
          "PASSWORD_BYTE_1": 0,
          "CUSTOM_PORT": 5987,
          "ADDR": "192.168.178.39",
          "PASSWORD_BYTE_2": 0
        }
      },
      "properties": {
        "sessionid": "N/A",  
        "sessionid_last_refresh": "N/A"
      },
      "uid": {
        "segments": [
          "milight",
          "bridgeV6",
          "575b7684"
        ]
      },
      "thingTypeUID": { 
        "segments": [
          "milight",
          "bridgeV6"
        ]
      },  
      "location": "Wohnzimmer"
    }
  }  
}

Is there is any action required to get the binding complete?


(Vlad Kolotov) #4

When you manually adding an ibox bridge you have to specify its MAC address. This means that you have to enter two things: IP and MAC address. That MAC address setting is hidden so that’s why I also could not get it to work.

You can find your MAC address by visiting the bridge web page:


(Thowa) #5

Thanks Vlad,

I already did it exactly like you mentioned.

Btw, how can I post a screenshot in this forum?


(Thowa) #6

I have changed the port in the Web Servcer Config page to 5987.
The iBOX2 is now being detected.

Thanks a lot


(Oliver) #7

I can’t pick up Ibox on openhab automatic how did you change the port number


(Simon#56) #8

Just a quick update from my side. I got this working today.

I have a Mi Light Wi-Fi iBox LED Controller (in OH seen as iBox/iBox2 milight:v6)

  1. installed the Milight Binding within PaperUI - binding-milight - 2.4.0.M4
  2. addded the ibox2 device to OH as a Thing
  3. confgured the IP address of the box (made sure it is connected to my WiFi, same network as OH)
  4. configured the MAC address (use SHOW MORE)
  5. configured the port 5987 (use SHOW MORE)

3, 4 can be opbtained from the web-interface of the iBox when it is successfully connected to your WiFi.
DO NOTE USE THE TCP PORT FROM THE iBOX, DO NOT USE 8899, USE 5987 INSTEAD