[SOLVED] Cannot install chromecast binding

Hi,

I have upgraded to openHAB 2.3.0 Build #1276 and I can no longer install the chromecast binding.

10:07:51.112 [ERROR] [.core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-chromecast': Error restarting bundles:
        Could not resolve module: org.openhab.binding.chromecast [250]
  Another singleton bundle selected: osgi.identity; type="osgi.bundle"; version:Version="2.3.0.201803141709"; osgi.identity="org.openhab.binding.chromecast"; singleton:="true"

Any ideas what might be causing this?

For now i’ve taken it out of my addon.cfg so the others can install ok.

Thanks,
Chris

It seems that the older version (2.3.0.201803141709) of the binding is still there and it is causing a conflict (?)

Check in OH2 console the list of bundles:

bundle:list -s |grep chromecast

Ps: Note that S1276 has an issue with the rules: WARNING - latest SNAPSHOT 1276. This shouldn’t be related to your case but you may want to downgrade to S1275 just in case.

Thanks for the reply, I will take a look in a while.

Thanks for the hint. I forgot that quite a while ago i was helping test the chromecast binding and still had that in my addons folder. uninstalled, deleted the jar and installed again all good and working :slight_smile:

1 Like