[SOLVED] Cannot install openhabian on Raspberry Pi Zero W


I am trying to install openhabian on Raspberry Pi Zero W. I am following instructions on https://www.openhab.org/docs/installation/openhabian.html but I am doing something wrong I guess.

On my PC with Ubuntu OS I have flashed image from https://github.com/openhab/openhabian/releases on SD card 32GB, entered SSID and password on openhabian.conf file. Then I have inserted SD card to Pi0W and plugged in power.

As it says in documentation, I do not see installation status on http://openhab/ . But using IP address, I see window with text:
" openHABian Installation Status
the log will be refreshed automatically every 10 seconds".

And below that there is text:
" openhab ’s server IP address could not be found." That’s it.

I have tried several times from 1 hour to 8 hours, but nothing has changed. I cannot get to the OpenHab dashboard either.

Just for the record I do not have HDMI screen, so I can not see what is happening on Pi0W.

Can anyone help me?

A RPi0W is below the minimum recommended specs to run openHAB. You need something the equivalent or better than an RPi 2. It should install but you won’t be happy with the performance. There isn’t enough RAM.

Should be http://openhabian:8080

I recommend installing a stock Raspbian Buster Lite and get the RPi online with wifi and ssh using the Raspbian provided instructions for a headless install (search google for tons of tutorials). Then install openHABian following the manual instructions through ssh so you can see the output and any errors.

The little information we have so far indicates there is something wrong with the network configuration.

1 Like

Thank you for your time, Rich!

I can’t get to http://openhabian:8080 either. I will try your recommendation and will back with the outcome.

So I have installed Raspbian Lite and OpenHab2 as described here: https://www.openhab.org/docs/installation/linux.html#package-repository-installation

Now I am facing this:
sudo systemctl status openhab2.service
â—Ź openhab2.service - openHAB 2 - empowering the smart home
Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled; vendor pre
Active: activating (auto-restart) (Result: exit-code) since Fri 2019-11-15 16
Docs: https://www.openhab.org/docs/
Process: 5548 ExecStart=/usr/share/openhab2/runtime/bin/karaf $OPENHAB_STARTMO
Main PID: 5548 (code=exited, status=1/FAILURE)

It is not active and I do not know what to do next… Any ideas?

Did you install the prerequisites? In particular did you install Java Zulu?

If you use openHabian then the hostname will be openhab (that changed in the latest release) and the installation status will be visible on the 80 port, so http://openhab should be the place to look for during installation…

1 Like

Yeap, that was the case. Thank you very much, Rich! It’s now working.

To not create another topic, I will continue here. I have installed OH, Samba and now trying to access to Raspberry Pi folders in order to make changes via Visual Studio Code. On files explorer (I am using Ubuntu OS) I see network RASPBERRYPI. There I see “homes”, “openHAB2-conf”, logs, userdata, print. But can’t access to any of them. I am asked to enter username, domain, pass. I am entering same as Samba, but it didn’t work… Does anyone has any ideas?

Also on Visual Studio Code as I want to open folder, I don’t see this network folders. Am I doing something wrong?