[SOLVED] Can't connect to local console


i am running openhab2 on a debian linux since it came out and experiencing now a new problem: I can’t connect to the console anymore. Version is the newest “testing”, port is open:

tcp6       0      0          :::*                    LISTEN      13746/java

and i get the following:

root@openhab:~# ssh -p 8101 openhab@localhost
Connection reset by port 8101

Any suggestions?

Thanks and best regards, Jens

Are you using the apt package? Does the command:

openhab-cli console 

get you in?

If this is a manual zip install, go to your openHAB home directory and use the command:


i am using the apt-package…

root@openhab:~# openhab-cli console 
Logging in as openhab
Session is being closed

does not work either…

Is there a chance that your IP address has changed? I initially had mine set at After my last reboot it lost that location and got reset to I have to lock it down to a set IP address.

no… no change in IP address… And i am trying to connect from the device itself to localhost :frowning:

i fixed it… executed "openhab-cli reset-ownership " and restarted. Now the console is back up again :slight_smile:


Glad you got it solved! there must have been a permission issue with either /var/lib/openhab2 or /usr/share/openhab2.

I had this same issue. I found an error message in openhab.log saying the key in /var/lib/openhab2/etc/hosts.key was unable to be parsed.

Deleting hosts.key solved the problem.

1 Like

I had this issue when i moved the openhab installation from a Linux laptop to a raspberry pi. I made a backup from the first and restored it on the latter. Everything looked ok but I could not connect to local console. Openhab-cli reset ownership solved this problem.
Thank you for the tip!