[SOLVED] Can't link openhab with Google Home


I am Using a Raspberry Pi 3+ with openhabian. I integrated devices over MQTT and Philips Hue, at the moment.

I want to connect my Openhab with Google Home. I created a myopenhab account and I can control my openhab from everywhere. When I try to link my Openhab with Google home, over the Home app, it says after “Connected to openHAB-account” -> “The setting could not be updated. Check your connection.”.
Under https://myopenhab.org/applications it says, that Google is linked, but in the Home app not.

I tried with a different phone and google account, same thing.

I am missing something? A binding or Port? Is this not working for germans?


Here are the full instructions.

EDIT: Corrected link above.

Hi Florian, and welcome to the OH community!

It’s tricky to answer questions without having enough background information, as every OH installation is a bit different and we don’t know anything about yours. Can you review this post with tips for asking questions?

It’s possible that the answer is already in another thread, so people here like to see that someone has done a search first. If you can’t find your answers via search, then following the steps above can save a lot of time as we work together on solving your problem.

As the post above notes, we’re here to help, but we’re all volunteering our time. Hopefully we’ll get you sorted out so that you can contribute as well.


I’ve been following this guide.

Hey, thanks!

you are right, there are missing some information!

I am Using a Raspberry Pi 3+ with openhabian. I integrated devices over MQTT and Philips Hue, at the moment.

I was searching for this problem (not linking to Google Home) in different forums, not only openHAB. But the problem of the other people is the that they can’t sync her devices with Google Home. My Problem is, that i can’t link openHAB to Google Home. I tried to delete my Home and different devices/accounts, same problem.

I installed the openHAB Cloud connector and gives all light-devices the Tag [“Lighting”] and [“Switchable”].

This how i try to link:

Because I can post only one picture per post here is my Cloud connector and myopenhab.org My Application:

Deleted my myopenhab account and created a new one with a new email. Same Problem.

Found the problem. Its was the double tag on the switches.


Switch Zimmer_Deckenlampe_Toggel “Deckenlampe” (gLight) [“Lightning”, “Switchable”]


Switch Zimmer_Deckenlampe_Toggel “Deckenlampe” (gLight) [“Switchable”]

That’s happens when you only copy and past…

1 Like

Good stuff, Florian. I haven’t been back in here since posting to you, so I’m glad you got it sorted out!