[SOLVED] Cant Remove Binding

I have a binding enabled, Souliss 1.3.0. I’m trying to remove it without success.
I remove it from file addons.cfg from line:

binding = caldav-command1,caldav-personal1,http1,netatmo,network,ntp,exec1,exec,mihome,zoneminder,chromecast,mqtt

and I uninstall from PaperUI. The results is that Binding go on working and writing logs, and if I reboot OpenHab, the binding is still installed in PaperUI, but if i do a bundle:list into console, binding is not present but still working fine.

How can I remove it definitively?


In the Karaf console find the binding id number, it’s the number on the far left on the line next to the binding name you want to remove.

Use this command to get the list


Once you know the binding id, use this command to remove it:

bundle:uninstall xxx (xxx is the number from the list above)

You should be good to go after this.


Hi @KidSquid
Bundle is not listed with bundle:list in karaf console, but still working fine and be installed from PaperUI


Sorry I missed that…i have not encountered a binding before that would not show up with the list command. Hopefully others can shed some light.

@marcolino7 Clean the cache then reboot.

sudo systemctl stop openhab2

sudo openhab-cli clean-cache

sudo reboot

thanks for help, binding is back to list in ssh console.


Simply cleaning the cache didn’t work then try deleting /var/lib/openhab2/config/org/openhab/addons.config. Doing this will regenerate the file and hopefully solve the issue.

Note: Please use sudo systemctl stop openhab2 before deleting the file above.:wink: While you have it stopped I would go ahead and clean the cache again then reboot.

perhaps I do not explain well, cleaning cache worked for me.


Glad it worked.:+1:

If you would please mark the topic as solved by clicking the square box on the post that provided the solution and edit the title to start with [Solved]. This will help others with a similar issue find a quick solution.