[SOLVED] CC2531 Zigbee Coordinator Init Always Fails

With the zigbee binding build, the initialization of a CC2531 coordinator always fails. It seems the zigbee binding attempts to open the zigbee serial port a second time after it succeeded in opening and starting initialization at the time the binding was started.

I have created a new issue for this problem: org.openhab.binding.zigbee issue #50

After further investigation, it looks like the coordinator’s serial port is opened OK when OH2 is first started, but nothing – coordinator nor devices – is shown as ONLINE. When the zigbee bundle is restarted, the coordinator initialization fails when it attempts to open the serial port, which I surmise must not have been closed when the bundle was stopped. Restarting OH2 yields the same result.

@chris created a test version of the ZigBee binding that corrected the issue where a restart of the bundle left the coordinator’s serial port open. If you read the thread in the issue report linked above, you will see that I had to delete and recreate my zigbee things and item links.

Now the only remaining problem for me – for which I have yet to create an issue – is that my Tradfri bulb no longer works with the ZigBee binding. The Tradfri bulb is discovered, but it cannot be controlled.