[SOLVED] cellMotionAlarm not working with 3.3.0.M1

I have a OH 3.2 running in docker with Reolink RLC-811A. I added the camera as onvif type and get cellMotionAlarms to OH in case the camera detects motion.
I then upgraded to 3.3.0.M1 and found that cellMotionAlarms are not generated. So I reverted back to OH 3.2
What kind of data shall I provide for analysis?

I have attached a trace having error messages I do not understand
Trace.txt (17.8 KB)

Did you try to do a reboot or 2 at all? There are two theories:

  1. The binding or openHAB glitched and doing a pause and unpause of the thing would have reset it and possibly made it work. If this is the case then we need someone to say what needs to be done to reproduce the behavior. When you do an upgrade it will clean out the cache and this requires a few restarts for the cache to get rebuilt and for openHAB to restart in a normal way again. This can effect any binding and is not a fault of the binding if it only happens directly after upgrading and only doing 1 restart.

  2. Line 1658 in IpCameraHandler.java was changed to try and reconnect every 8 seconds instead of every 30 seconds, perhaps this change did not like your camera/system/setup, but I think this is unlikely unless the camera takes a very long time to respond. All the other changes to the code between your mentioned versions are for MJPEG streaming and could not effect what your seeing.

I suspect it will be number 1 and will probably be solved by a few reboots, or maybe just a pause and unpause of the thing.

2022-02-11 20:09:03.102 [WARN ] [io.netty.channel.AbstractChannel    ] - Force-closing a channel whose registration task was not accepted by an event loop: [id: 0x0dc00cab]
java.util.concurrent.RejectedExecutionException: event executor terminated

This would happen if the binding did not start up the ONVIF connection correctly which the code did not change, it only occurs more often in the 3.3 versions.

Thank you for your response. I followed the advice. Rebooted the system, left it running for 10 min, then another reboot. Did this 3 times. No everything is working as expected. I have the feeling that MJPEG displays faster on habpanel than in the 3.2 version.

So issue is solved