[SOLVED] Chart is not displaying values

I would like to have some temperature values in my charts and although I´ve added everything and also set the persistance, no values are displayed in the chart.
The chart item itself is shown well, but apart from hours on the x-line and “0” on the y-line, there is nothing.

I´ve setup several charts in the same manner for other temperature sensors, they work fine.

Could someone kindly tell me what I´m doing wrong here?

Number Sauna_Temperatur "Sauna Temperatur [%.1f C]" { channel="zwave:device:95123ab1:node38:sensor_temperature3" }

Text item=Sauna_Temperatur label="Sauna Temperatur: [%.1f °C]" icon="temperature"
Chart item=Sauna_Temperatur refresh=6000 period=D

Persistance rrd4j:
Sauna_Temperatur : strategy = everyMinute, everyChange, restoreOnStartup

There was the same topic a couple of hours ago.
The OP hasn’t come back to me
Try adding a label to the chart:

Chart item=Sauna_Temperatur label="Sauna Temperature" refresh=6000 period=D

It wasnt me with the same topic and I also tried to search first…

anyway, it didnt help. still nothing in the chart.

I think I’m the OP you are referring to.

I replied a few minutes ago, adding label did not fix it.

Any idea what Im doing wrong?

Do you have a corresponding .rrd file for the persisted item? Location should be: /var/lib/openhab2/persistence/rrd4j

Additionally if you have Rest Docs installed you can check if there are any entries in the database for that item.

yes, there is a corresponding rrd file in the persistence directory
there are also some cryptic values (tried to open with notepad++)

so I´m still wondering why nothing is displayed in the chart

I you have the REST Documentation installed, you could check the actual entries in the database. If you haven’t installed, it can be found on PaperUI under Addons-Misc.

Go to
and select the REST Api
Open the Persistence GET /persistence/ items/{itemname} page
On that page insert “rrd4j” as serviceID and the item name in question. Hit the " Try it out" button and you should get a response with all values stored for the last 24 hours.

If you get no values, the setup probably needs a stop of openhab, delete the rrd file and start openhab.

Tried out… no luck, even after a restart.
For other charts its working fine.

Absolutely no idea why it doesn´t work here :frowning:

Let’s put all together what we know so far.

You haved other itemes that are persisted and that do show in a chart. Assuming that those items use rrd4j as well the failure can’t be the missing setting for the querried persistence service (Could either be set in the Chart line or the Default as set in PaperUI could be used).

The actual values of the item shows on the sitemap, so you are using the correct channel.

You have a rrd file, hence the items at least has been persited once, hence the problem is NOT to be found in the rrd4j.cfg.

You did stopp openhab, delete .rrd file in question and restarted openhab. After that the .rrd file was recreated. Agian the problem is NOT to be found in the rrd4j.cfg.

What was the result on the check via the REST API?

As a LAST try I would delete the item and recreate it, either via the .tems file or via PaperUI (depending on how you create items).

please apologise for the late reply, I was not able to work on my OH in last months.

Just tried to check via REST API as you described.
All I get:

“name”: “Sauna_Temperatur”,
“datapoints”: “0”,
“data”: []

Before I did following:

  • shutdown OH
  • renamed item/sitemap entry
  • deleted rrd file
  • started OH
    I clearly see values sent by this sensor, and they are also shown in the basicUI, but still no chart. :frowning:

I found the problem!

The whole time I was editing a “rrd4j” file instead of “rrd4j.persist”, therefore no strategies were stored.
now everything works as expected.

Please apologise my stupidity and many thanks for your help!