[SOLVED] Color Temperature Slider

Hello everybody,

I am an absolute beginner with MQTT and OPENHAB.
I flashed my LSC Smart Connect LED with Tasmota.
Now I would like to have a slider for the color temperature in OPENHAB. However, the sliders can only be used from 0-100 percent, but the color temperature ranges from 153 to 500.
Does anyone have a tip on how I can do this?

Translated with DeepL from Germany

From the first view i would suggest that you create an outgoing transformation that maps the 0 to 100% to 153 to 500 value. The should be an option in mqtt.

Could you give use some more Information. Your Item definition, your Thing definition are you working with file or paper ui or mixed.

Great that you made the step to forum with deepl

Thanks for your answer.

What exactly do you mean by item definition and thing definition? Sorry, I’m still very new :smiley:
I work with the Paper UI.

I can read English but for you to understand me better I prefer to have it translated by DeepL. :wink:

Deepl is fine i use it very often.

OK, you flashed your device with Tasmota.

Is your device already connected to openHAB? For example have you configured a switch that switches the device on /off?

Yes it is already connected to OpenHAB.
A switch, dimmer and RGB color slider is also configured.

Sound good. Next step should be to configure a slider to use with color temperature. Just di it like the dimmer or RGB Slider and the post a screen shot. Typically you will have a more button on the screen just use it to see al the options.

1 Like

These are the settings for the color temperature slider.
I think my thinking error is the absolute minimum and absolute maximum, this is about setting a limit between 0 and 100. But I have no idea how else to configure it.

Ok fine i tought that the where a similar option to the incoming Transformation, but for output it is only formatting.

In my world i would build a rule that coverts the value and sed it out via a mqtt action.

Maybe someone else could step in, because i am very busy at the moment.

Some Hints:

1.) Create an dimmer item
2.) Create a rule that is triggered by the dimmer item and that calculates from the dimmer value the correct output value. Them publish the value with a mqtt action.

Havent done that on my own, but in general it should word.

Then I have to hope someone will help me with the rule.
Unfortunately I have no idea about it.

But thank you for your Help!

It’s probably worth reviewing openHAB architecture.

Real-world devices are represented as Things in OH, in bindings that convert to different device technologies…

Things have channels to link them to openHAB Items.

Items are openHAB’s simple internal model of the world - switches, numbers, dimmers. Rules and user interface operate on these Items.

PaperUI is an administrator’s interface - it allows you to alter e.g settings of channels, and offers test tweaking of values, but it does not provide any control over what is displayed.

The proper user interface - you would choose from BasicUI or ClassicUI or HABpanel or other apps - allows you to tailor the display and controls that you want.

So, when you say -

really you have configured a channel, and made it a dimmer type.
Normally you would link that to a Dimmer type Item for further use in your UI or rules.

In openHAB’s world of simple Items, Dimmers are always 0%-100% objects.
I believe you are using the channel’s “absolute Minimum” and “absolute Maximum” settings in the correct way here, to convert 0-100 into 153-500.
I am not so sure these work properly in all OH versions though.

You can monitor what MQTT messages are sent by using some third party tool, like mqtt.fx

I tested it again and logged it with MQTT.fx. It sends the absolute minimum and absolute maximum to 153 and 500 only the command with values from 0-100, even after a restart of my Raspberry.

maybe i should check if there is an update of openhab or which version is installed.

I feel like a noob :open_mouth:

On my phone so I can’t give any code examples.

If you use a snapshot version of openhab you can set minValue and maxValue for a Slider on a sitemap. Use a Number item instead of a Dimmer.

If you running version 2.4 you will have to use a rule to translate the 0-100% into 153-500 mired.

If you are running version 2.5 you should check if you have the version 2.5 MQTT binding. If you use it you can have it do the translation using the min and max options in the channel configuration.

It’s not clear what that means.

As per that linked post (click to read the whole thing) you would need 2.5 M1 or later.

okay, i installed

i tried to upgrade via openhabian-config…but it stays at am i doing something wrong?

I don’t know, not an openHABian user and cannot see what you are doing. You might look for clues.

Yes you are using stable and 2.4 is the most recent stable. You would have to switch to a milestone or snapshot version which are testing versions
updating to a newer version of openhabian is currently broken! the location of the download to install java moved from where it is hardcoded into the script and the install fails. There is a workaround but it requires editing the scripts.
I know you said you were a beginner so now your head is probably really spinning. Search openhabian install or upgrade failed in forum for more info on that situation.

Rossko… this is one of the best OpenHAB in a nutshell descriptions I’ve ever read. This should be the first paragraph in the new user docs, like the tl:dr

i actually had the problem with the first installation of openhabian. i changed 2 scripts according to the instructions and then the java installation worked.

But I’m a little afraid already

Perhaps to add confusion, it’s only the MQTT binding you need to update really.
Upgrading the whole system is a bit scary until openHAB gets a new stable release, and openhabian release catches up with that

But individual bindings can be upgraded. There is no guarantee that example binding 2.5.99 will work on base openHAB 2.4, but they usually do.

If it were me, I would look into whether current MQTT binding works on 2.4 and how to upgrade to it.

i just updated openhab to the latest snapshot now.

In case of emergency I simply go back to my backup