[SOLVED] Compatibility Issues: systemd[1]: Failed to start /etc/rc.local Compatibility

Using openHABian on a Raspberry Pi 2. Used the lasted image from OpenHAB, also used Etcher to flash the card. The card was also formatted before flashing. I am able to access the openHAB initial setup page just fine and can install whatever add-ons and use Paper-UI. I had the same issue error, but I used an SD card that had Raspian on it, and didn’t bother to format first before flashing with OpenHABian image. Also before, it would also freeze up on me. As in I could not SSH into it, even the monitor hooked to HDMI was frozen. After the format and the Fresh flashed image, I haven’t had a freeze up…YET… But I still have the same error…

Here is what I get with the sudo systemctl status rc.local…

● rc-local.service - /etc/rc.local Compatibility
Loaded: loaded (/lib/systemd/system/rc-local.service; enabled-runtime; vendor preset: enabled)
Drop-In: /lib/systemd/system/rc-local.service.d
Active: failed (Result: exit-code) since Fri 2020-01-31 12:53:41 CST; 11h ago
Docs: man:systemd-rc-local-generator(8)

Jan 31 12:37:39 openhab gpasswd[17091]: user openhabian added by root to group openhab
Jan 31 12:40:38 openhab groupadd[17493]: group added to /etc/group: name=rdma, GID=116
Jan 31 12:40:40 openhab groupadd[17493]: group added to /etc/gshadow: name=rdma
Jan 31 12:40:40 openhab groupadd[17493]: new group: name=rdma, GID=116
Jan 31 12:41:29 openhab groupadd[17635]: group added to /etc/group: name=sambashare, GID=117
Jan 31 12:41:29 openhab groupadd[17635]: group added to /etc/gshadow: name=sambashare
Jan 31 12:41:29 openhab groupadd[17635]: new group: name=sambashare, GID=117
Jan 31 12:53:41 openhab systemd[1]: rc-local.service: Control process exited, code=exited, status=1/FAILURE
Jan 31 12:53:41 openhab systemd[1]: rc-local.service: Failed with result ‘exit-code’.
Jan 31 12:53:41 openhab systemd[1]: Failed to start /etc/rc.local Compatibility.

It looks like to me as if there is an issue with a group being created for Samba… IDK. This is my first ever with Raspberry Pi, OpenHABian, and Linux… I have done some searching, but it all shows up as a ZULU issue…

As of now though, everything is working fine. The fresh flash was made about 12 hours ago… So we will see if it freezes on me again…

Any Link, Help, Advise, Search Query would all be helpful.

Thanks Again Everyone!!!

Hopefully all keeps running smooth for you :smile:, but if not, there are multiple possible reasons for your issue, including hardware issues… Freezes and other ‘random’ behaviour often point in the direction of SD card or power supply issues. They can be very obvious (“it doesn’t work”) or very vague (“sometimes - not reproducible - it hangs or gives a weird error”).
If it freezes again I recommend to try another SD card first.

You said you formatted the SD card first. Did you use the sd card formatter program recommended by Raspberry Pi? I have sometimes seen that fix card issues.
You could have just installed OpenHABian on Raspian by following the Linux installation instructions. The image is basically Raspian Lite anyway.

I’ve never needed to format first when using Etcher so try a different SD card or try to install Noobs or Rasbian lite on the Pi. If nothing installs then it’s either the card, Pi, or PC used for flashing.

I figured those that made the Pi and customized Debian to make Raspbian had a good reason to say you needed to use the formatting application. In my mind it was not worth questioning just to save a little time.

I am using is a CanaKit 2.5A for my Raspberry Pi 2. The card I am using most likely has been used for quite awhile with various school projects. I will replace the SD card and see where that gets me.

CanaKit makes good stuff so the power shouldn’t be an issue but you may still want to verify with a meter if you have one. Even the good stuff will eventually go bad.

A new SD sounds good. :+1: Be sure to make a backup of your OH config (also test that it works) so when the new card fails you won’t have to start from scratch. One other thing to mention, if you plan to use this as a primary server, is upgrading to a Pi 3 B+ or higher as you can use an SSD hard drive no SD card needed.

Got a new SD with new image flashed onto it. I am now using a Raspberry Pi 3B+… So far everything is a go… I have none of the errors from before. Thanks all for the suggestions!!!

1 Like

Glad you have it working. :+1:

Usually, the main problem is either the power supply or the SD card. Most that commented have seen this issue multiple times here on the forum. As mentioned, glad you have it working and please click the square box on the soltuoin post.

Consider enabling ZRAM to avoid have it happen again.

1 Like