[SOLVED] Configuration Parameters menu missing from Z-wave device in HABmin - Remotec ZTS-500

Tags: #<Tag:0x00007f43319bd5b8> #<Tag:0x00007f43319bd4c8> #<Tag:0x00007f43319bd130>

Found it:

grafik

When I hit “Request Review” I do not receive an email about that or its approval. I do not see a profile setting for that either.

No, you only get this with elevated database rights :heart_eyes:

1 Like

Thanks for the replies!

Ah, I missed the update notes and timestamps at the bottom of the page. Good to know.

So, need to update to the latest version, 2.5. Which means I can’t use Paper UI, since it pulls 2.4. I know how to add a *.jar file to the \openhab2-addons folder, from using another binding.

However, the last post I can find pointing to the latest snapshot build is for 2.4:

I can see on Github that there is a 2.5 release, but for the life of me, I can’t find a link to that snapshot *jar download. Did I miss it somewhere in the documentation?

Please let me know if I need to build the jar myself from source (although I need to research how to do that, haven’t built any Java code before… but how hard can it be? :wink:

EDIT: So, shooting in the dark, I replaced 2.4 with 2.5 in the download link, and what’d ya know? I can download the 2.5 snapshot! Next question (probably a silly one, but just to be sure): is the snapshot updated regularly when changes are made on Github? Nevermind, the date should be visible after installation in the console using grep.

anyhow fellas… I am almost positive Chris uncovered a buggy and fixed missing parameters in Habmin & Paper UI if not mistaken, but I am talking days ago so probably no merged yet or only in bleeding edge snapshot.

He is also still struggling to get a development environment going I think

ummmm… this might be a good use for Scott’s install script???
never used but maybe somebody chime in??

@Diogenes
check out this thread for zwave install script which may help you get an upgraded zwave binding going. Read the instructions and info in this thread

I don’t know if an upgrade of OpenHAB is going to be neccesary. I am running OpenHAB stable 2.4 and a zwave snapshot

I am running 2.5M1 with a snapshot zwave binding installed using the script. I seem to recall somebody trying a snapshot binding on 2.4 and having issues until they upgraded to 2.5M1.

Thanks, I will.

I grabbed the 2.5 snapshot from a modified link supplied by Chris in another post. Then installed the binding and followed the instructions here. I also had to manually install the transport-serial package (this step is probably included in that script, to which @Andrew_Rowe pointed me).

But after install, the menu for the device’s configuration parameters is still not displayed. Also I see the date for the binding shown as:

openhab> bundle:list | grep ZWave
270 x Active   x  80 x 2.5.0.201901201452     x ZWave Binding

The Jan 20, 2019 date matches the release on Github for 2.5.0.M1. So am I correct in assuming that the link Chris supplies is for the official release that he uploads to his site only for major revisions?

Since @sihui and @Bruce_Osborne pointed out that the database file for the device in question was updated after this (2019.03.12), this means I need to be building the latest from source, or using the install script.

I’ll report back when I’ve tried one. I might install an IDE and attempt to build myself, since I have other bindings that also provide daily updates, and it would be nice to be able to build all of these at will.

Don’t make it too complicated, just grab the latest from here:

https://ci.openhab.org/job/openHAB2-Bundles/org.openhab.addons.bundles$org.openhab.binding.zwave/

2 Likes

The readme for the script has instructions for doing everything manually, including a URL for the latest snapshot of the binding. The link you used should be removed… it was used for testing. This is actually an option in the script too (the development option), since Chris sometimes provides builds for people to test.

Instructions for xstream are in there too! :wink:

1 Like

hits Bookmark button eighteen times

Perfect! I did not know this existed, thank you very much. Might I recommend that link be added to the zwave binding README on the Github front page? It might help others find the latest *.jar file.

Thanks for the tips. Which link?

Also, delete all your zwave Things & rediscover them.

This one:

This is not just a download page for the zwave binding, but also for the whole openHAB project, therefore you can find that link in the docs:

Snapshot: Benefit from the latest changes in the daily created snapshot (hosted on openhab.org).

Done.

Ah, oops. I’ll keep my recommendations to myself… :relaxed:

This one (Chris would have to remove it from his post)…

Upgrading to the latest Zwave binding snapshot did the trick. Configuration Parameters show up and can be updated via HABmin.

Many thanks for everyone’s help!

2 Likes