[SOLVED] Configuration Parameters menu missing from Z-wave device in HABmin - Remotec ZTS-500

Trying to securely include my thermostat into the network, and noticed that the Configuration Parameters menu is missing from the menu list in HABmin.

I see that the parameters are listed in the Chris’ Device List, yet they don’t show up in HABmin. My other devices, dimmers and such, show up correctly and I am able to send config updates to those devices via HABmin as expected.

Is this a problem with the device XML file (a cursory inspection of the XML file by my untrained eye did not reveal any obvious issues), or a problem of HABmin? I would assume this specific device, since other devices work normally.

Thanks in advance for the help.

Hardware: Raspberry Pi3
OS: openhabian 2.4.0-1 (Release Build)
HABmin: 2.0.0, 2018-12-17T00:31:22
Z-wave binding: 2.4.0 (installed via Paper UI today)
Z-wave controller: Aeotec Z-Stick Gen5

Attached: Device XML file from \openhab2-userdata\zwave network_e9d17e69__node_4.xml (14.0 KB)

Screenshot from HABmin:

If it is listed on the site, it was likely added after 2.4. I think it was added after 2.5M1.

I would recommend updating to 2.5M1 and then manually upgrading the zwave binding to a snapshot version.

I think @chris and @sihui would agree.

1 Like

Initial adding to the database was on 2018-11-07, type:id 0200:8170 was added 2018-08-24.
Config parameters were added 2019-03-12, so it needs a 2.5 snapshot zwave binding to show up.

1 Like

Here is what I see.

My findings are from the emails I received upon hitting the “Request Approval” button.

1 Like


Is that a level after “Request Review” ?

I don’t remember the correct terminology :joy:
I meant the button which needs to be clicked after you have made all the changes and one wants to have the device be approved.
Is it “Request Approval” or “Request Review”?

1 Like

I do not get emails. I guess that is a profile setting.

No, misunderstanding.
You have edited the database, now you need to hit a button “Request something”. I don’t have this button …

Found it:


When I hit “Request Review” I do not receive an email about that or its approval. I do not see a profile setting for that either.

No, you only get this with elevated database rights :heart_eyes:

1 Like

Thanks for the replies!

Ah, I missed the update notes and timestamps at the bottom of the page. Good to know.

So, need to update to the latest version, 2.5. Which means I can’t use Paper UI, since it pulls 2.4. I know how to add a *.jar file to the \openhab2-addons folder, from using another binding.

However, the last post I can find pointing to the latest snapshot build is for 2.4:

I can see on Github that there is a 2.5 release, but for the life of me, I can’t find a link to that snapshot *jar download. Did I miss it somewhere in the documentation?

Please let me know if I need to build the jar myself from source (although I need to research how to do that, haven’t built any Java code before… but how hard can it be? :wink:

EDIT: So, shooting in the dark, I replaced 2.4 with 2.5 in the download link, and what’d ya know? I can download the 2.5 snapshot! Next question (probably a silly one, but just to be sure): is the snapshot updated regularly when changes are made on Github? Nevermind, the date should be visible after installation in the console using grep.

anyhow fellas… I am almost positive Chris uncovered a buggy and fixed missing parameters in Habmin & Paper UI if not mistaken, but I am talking days ago so probably no merged yet or only in bleeding edge snapshot.

He is also still struggling to get a development environment going I think

ummmm… this might be a good use for Scott’s install script???
never used but maybe somebody chime in??

check out this thread for zwave install script which may help you get an upgraded zwave binding going. Read the instructions and info in this thread

I don’t know if an upgrade of OpenHAB is going to be neccesary. I am running OpenHAB stable 2.4 and a zwave snapshot

I am running 2.5M1 with a snapshot zwave binding installed using the script. I seem to recall somebody trying a snapshot binding on 2.4 and having issues until they upgraded to 2.5M1.

Thanks, I will.

I grabbed the 2.5 snapshot from a modified link supplied by Chris in another post. Then installed the binding and followed the instructions here. I also had to manually install the transport-serial package (this step is probably included in that script, to which @Andrew_Rowe pointed me).

But after install, the menu for the device’s configuration parameters is still not displayed. Also I see the date for the binding shown as:

openhab> bundle:list | grep ZWave
270 x Active   x  80 x     x ZWave Binding

The Jan 20, 2019 date matches the release on Github for 2.5.0.M1. So am I correct in assuming that the link Chris supplies is for the official release that he uploads to his site only for major revisions?

Since @sihui and @Bruce_Osborne pointed out that the database file for the device in question was updated after this (2019.03.12), this means I need to be building the latest from source, or using the install script.

I’ll report back when I’ve tried one. I might install an IDE and attempt to build myself, since I have other bindings that also provide daily updates, and it would be nice to be able to build all of these at will.