[SOLVED] Configuring the Tesla thing

  • Platform information: Ubuntu Linux 16.04
    • Hardware: PC, 64
    • OS: Ubuntu 16.04
    • Java Runtime Environment: Java™ SE Runtime Environment (build 1.8.0_171-b11)
    • openHAB version: 2.3.0
  • Issue of the topic: Cannot configure the Tesla binding/thing

Hi, I am new to openHAB and I am trying to configure a Tesla thing to run some automation on my car.

I successfully installed the binding (no questions or configurations were required. In a next step, I added the tesla thing and entered email address, password as used on the my.tesla.com login page as well as the correct VIN.

Looking at the status of the Tesla thing it now says:
Status: UNINITIALIZED - HANDLER_REGISTERING_ERROR org.glassfish.jersey.client.JerseyClientBuilder cannot be found by javax.ws.rs-api_2.0.1

The car is reachable.

I suspect something went wrong with the token.

Any ideas?

Heinz

Question is, do you own a Tesla Model S?
Since the docs tell me that only the Tesla Model S is supported.

Yes, I do and I can reach it from my mobile phone.

Just discovered, that I might have a problem with my java installation: org.glassfish.jersey.client.JerseyClientBuilder cannot be found by javax.ws.rs-api_2.0.1

I am not a java geek. Does anyone know how to fix this problem?
Thanks
Heinz

Could post the full openHAB log? Its better for us geeks to figure out whats going wrong :wink:

Got it to work as follows (remember Ubuntu/Linux platform):

  1. Deleted everything
  2. Downloaded jersey client (ziped jar files)
  3. Installed jersey-client and jersey common in /usr/lib/jvm/java-8-oracle/jre/lib/ext
  4. Re-istalled openHAB
  5. Setup the Tesla binding and thing -> online!

Heinz

I had the same problem but fixed it in a different way. I think maybe openhab2.3 jersey is messed up somehow. Do any others have problems with bindings that use it? I’ll have to try 2.4 when I get a chance.

The binding will start. It still generates some errors but seems to work (mostly). I have a model 3 so some of the issues could be that…

2 Likes