[SOLVED] Conflicting bindings

I have some conflicting bindings and do not know how to remove all but the 3.4.0.M2 version:

openhab> feature:list |  grep mercedes
openhab-binding-mercedesme                        │ 3.4.0.M2         │          │ Uninstalled │ openhab-addons-3.4.0.M2                       │ MercedesMe Binding
openhab-binding-mercedesme                        │ 3.4.0.SNAPSHOT   │ x        │ Started     │ org.openhab.binding.mercedesme-3.4.0-SNAPSHOT │ MercedesMe Binding
org.openhab.binding.mercedesme                    │ 3.4.0.SNAPSHOT   │          │ Uninstalled │ org.openhab.binding.mercedesme-3.4.0-SNAPSHOT │ openHAB Add-ons :: Bundles :: MercedesMe Binding

When I perform

openhab> feature:repo-remove org.openhab.binding.mercedesme-3.4.0-SNAPSHOT

I get below error:

Removing features repository: mvn:org.openhab.addons.bundles/org.openhab.binding.mercedesme/3.4.0-SNAPSHOT/xml/features
Error executing command: java.lang.NullPointerException

How can I get rid of the snapshot versions? I have already cleared the cache several times, the addons folder does not contain a mercedesme binding?… no clue anymore.

Solved it myself by removing the folder

I see, but that’s a hard solution.

  1. If you installed the binding via Marketplace please try to remove it via Marketplace
  2. If you downloaded jar/kar and put it into addons folder simply delete them
  3. If above methods doesn’t apply just uninstall the unwanted bundles as shown below
openhab> bundle:list -s | grep mercedes
326 │ Active   │  80 │     │ org.openhab.binding.mercedesme
openhab>bundle:uninstall 326

I did all above, but did not work. As mentioned removing the marketplace folder did the trick.