[SOLVED] Connecting a New MQTT Device

Hi all, running 2.4 with the old mqtt binding. Have not taken the time to update to the new one yet.

I discovered tuya-convert and it has opened up a whole new world! I have several devices mostly sonoff’s that i have flashed in the past, the old way with solder, so this is amazing now.

I have a dual plug that i flashed with Tasmota. Thought i would be able to get it going no problem but running into issues. Here is a summary of what I am seeing.


//Tower Timer Cluster Two
Switch SOP04_US_Dual_plug1 "Tower Timer Two" <switch> (persist)  [ "Switchable"]
    { mqtt=">[broker:cmnd/DVES_5FE9FE/POWER1:command:*:default],
            <[broker:stat/DVES_5FE9FE/POWER1:state:default]" } 

Tasmota settings:


What I see in the log when i toggle the switch with the tasmota app.

15:56:55 MQT: tasmota/DVES_5FE9FE/stat/RESULT = {"POWER1":"ON"}
15:56:55 MQT: tasmota/DVES_5FE9FE/stat/POWER1 = ON (retained)
15:57:00 MQT: tasmota/DVES_5FE9FE/stat/RESULT = {"POWER1":"OFF"}
15:57:00 MQT: tasmota/DVES_5FE9FE/stat/POWER1 = OFF (retained)

Openhab log when I use the openhab app:

2019-10-03 11:19:10.045 [ome.event.ItemCommandEvent] - Item 'SOP04_US_Dual_plug1' received command ON

2019-10-03 11:19:10.068 [vent.ItemStateChangedEvent] - SOP04_US_Dual_plug1 changed from OFF to ON

I know its close. It just does not trigger the switch. Ie, physically… And nothing shows up in the tasmota console.


IMHO it would have worked if the Full Topic would be set to the default %prefix%/%topic%

Your MQTT topics are not the default

Switch SOP04_US_Dual_plug1 "Tower Timer Two" <switch> (persist)  [ "Switchable"]
    { mqtt=">[broker:tasmota/DVES_5FE9FE/cmnd/POWER1:command:*:default],
            <[broker:tasmota/DVES_5FE9FE/stat/POWER1:state:default]" }

Should work…

1 Like

@vzorglub: Hopefully the OP is following only one advise🤣

lol, very true! Thanks to both! I went with changing the topic. That did the trick. That also was a light bulb moment of figuring that part of the equation out.

thanks again guys!