[SOLVED] Controlling my Shelly 1 with Alexa and Openhab

Hi all, I am trying to control my shell 1 with openhab and alexa. Since I switched my shelly to MQTT it is of course off the cloud and alexa can not control it. I thought I could do this with the echo binding but it does not seem to work. Any ideas??


You can find all needed information in openhab documentation.

Echo binding is used to control Amazon devices from openhab. To control openhab devices from amazon the flow is a little bit another :slight_smile:

You can also use the hue emulation binding for a more local control. The above post uses the openhab cloud.

Hi first of all thanks. OK I have installed hue emulation and read about it but not sure what the next step is. It says it must be put into pairing but not sure how. Can you help further?

In paper ui under configuration then services then io. Click on the hue emulation.

Then ask alexa to discover.

Hmm I have done this but alexa finds nothing. I can see the devices in the alexa app but nothing happens when i turn them on and off. Shelly devices that is. I have one shelly 1 on the shelly cloud still and it works.

I am working with a Shelly 1 via MQTT and Alexa.
You should need to set up the MQTT binding and define an item to control the shelly via MQTT.
Ensure you are able to switch on/off via paper UI or any other openHAB UI (HAB Panel, IOS App or Android App, etc…).
If that works, ensure you have defined a good label in the item definition (Alexa works on the labels) and you have defined the tag for Alexa: [Switchable].
Install cloud connector using myopenhab.org (Alexa works through the cloud connector).
Then install the OpenHAB skill in Alexa, make sure you connect the skill to myopenhab.org and then add the devices from the Alexa app.

makes sense?

Hi thanks for your help. I had done most of what you said. I see the MQTT shellies in the alexa app but they do not respond to the app. It says the light is on or off but the actual light does nothing. maybe I did something wrong. Alexa also recognises the names of the lights but nothing happens when alexa turns them on or off. Any ideas??

Sorry, can you confirm you can turn lights on/off via paper ui?

Yes I have had the shellies connected via MQTT for at least a year and using openhab paper ui or habpanel, that all works fine.

Can you share the item definition?
Also, are you sure the cloud connector is working? Did you try to swtich on/off via IOS App or Android App, disabling the WiFi on the mobile phone?

Hi, Sorry I am not so good at this :sweat_smile: I am not sure what you mean by item definition.
On my app I can with wifi on all works but I can not even connect to remote when wifi is off. Actually I am not sure if I ever could. I tried my the same username and password as the local server.

Ok I figured that out. I can connect to the remote server. All works there now. Still no alexa though. It sounds like it sends the command. Alexa beeps as she normally does after a light is turned on but nothing happens.

Did you try to turn the shelly on/off with the alexa App and not via voice command?

You need to monitor the logs and see if any commands are getting from alexa to openHAB.

This should give you more insight.

Yes and it says waiting for allterco robotics. Then it says the light is on but it isn’t.

Mmm, might be that you are trying to control your Shelly via 2 systems in parallel as my understanding is that you have installed the “Shelly cloud” skill and the “openhab” skill. If you Shelly is working fine with openHAB you don’t need the Shelly skill to control it, just need openHAB skill connected to your home via the openHAB cloud conntector.
I would try removing the Shelly cloud skill from Alexa, remove the Shelly device from Alexa and then add new devices choosing category “other devices”, which should discover openHAB items.
Hope it works.

Yes I had both skills. I have deactivated the shelly skill and deleted the MQTT devices. Do I need to configure openhab cloud? I really appreciate you trying to help me…

I tried searching for other devicves in alexa app but it finds nothing. :man_facepalming: :man_shrugging:

@Steve_J I need a little reset to help.

Here is what you need: can you confirm the steps completed.

  1. Shelly Devices configured and working in openHAB using mqtt. Able to be switched in the ui
  2. OpenHAB cloud connector installed. Devices able to be controlled using my openHAB.org
  3. OpenHAB skill installed in alexa and connected to your myopenhab account
  4. Finally discover devices and test!

Hi everything is working up until I try to discover the devices. The skill says I am connected. It finds no devices