[SOLVED] Could not launch framework after latest snapshot update

Hi and Merry Christmas!

I just upgraded OH2 as per this

Now I’m getting the following error in openhab.log:

2016-12-25 10:32:10.302 [SEVERE] [org.apache.karaf.main.Main] - Could not launch framework
java.lang.RuntimeException: Could not resolve mvn:org.eclipse.birt.runtime/org.eclipse.osgi/3.10.2.v20150203-1939
        at org.apache.karaf.main.util.SimpleMavenResolver.resolve(SimpleMavenResolver.java:59)
        at org.apache.karaf.main.Main.createClassLoader(Main.java:410)
        at org.apache.karaf.main.Main.launch(Main.java:251)
        at org.apache.karaf.main.Main.main(Main.java:177)

Am I missing something?

Maybe you forgot:

# fix permissions
sudo chown -hR openhab:openhab /opt/openhab2 


I did that.

It’s strange, because I’ve doing this for weeks…

Then I would try deleting /userdate/cache and userdata/tmp and restart.

Edit: maybe restarting the server, not only openHAB could help …

same for me after upgrading :frowning:

Launching the openHAB runtime...
Could not resolve mvn:org.eclipse.birt.runtime/org.eclipse.osgi/3.10.2.v20150203-1939

cache and tmp are empty
I restarted the pi … no effect :frowning:

After this:

I got this (for sudo systemctl status openhab2.service):

● openhab2.service - The openHAB 2 Home Automation Bus Solution
   Loaded: loaded (/lib/systemd/system/openhab2.service; enabled)
   Active: failed (Result: start-limit) since Sun 2016-12-25 11:51:25 ART; 57s ago
     Docs: http://docs.openhab.org
  Process: 19089 ExecStart=/opt/openhab2/start.sh server (code=exited, status=255)
 Main PID: 19089 (code=exited, status=255)

Dec 25 11:51:25 zeus systemd[1]: Unit openhab2.service entered failed state.
Dec 25 11:51:25 zeus systemd[1]: openhab2.service holdoff time over, scheduling restart.
Dec 25 11:51:25 zeus systemd[1]: Stopping The openHAB 2 Home Automation Bus Solution...
Dec 25 11:51:25 zeus systemd[1]: Starting The openHAB 2 Home Automation Bus Solution...
Dec 25 11:51:25 zeus systemd[1]: openhab2.service start request repeated too quickly, refusing to start.
Dec 25 11:51:25 zeus systemd[1]: Failed to start The openHAB 2 Home Automation Bus Solution.
Dec 25 11:51:25 zeus systemd[1]: Unit openhab2.service entered failed state.

sudo ./start_debug.sh results:

Launching the openHAB runtime...
Listening for transport dt_socket at address: 5005
Could not resolve mvn:org.eclipse.birt.runtime/org.eclipse.osgi/3.10.2.v20150203-1939

Strange … I updated to #673 this morning without any problems. But I’m using the online snapshot and manual install.

Have a look here.

Sorry @Kai, had a look at that thread but it’s not clear for me how to solve this issue :sweat:

I was having the same issue. I backed up my conf and userdata directories, then wiped them out completely. After this it started ok. There must be something else in either conf or userdata that was causing issues. I had previously deleted the contents of cache and tmp before trying this.


I tried wiping out /opt/openhab2, downloading both beta (2.0.0.b5) and SNAPSHOT versions, installed from scratch and for some reason the runtime will not start. To worsen things, opehab.log contains nothing :frowning:

I restarted my Pi several times.

Any ideas?

Wrong java version?
Should be Oracle java greater than 101.

I am using docker and updated to the latest snapshot for my install. I have /openhab/userdata and /openhab/conf both mounted outside of the docker container so the I wouldn’t expect the update/upgrade to take care of it.

I think the procedure then would be that if you pull a new docker image you will need to…
clear /openhab/userdata/tmp
clear /openhab/userdata/cache
clear /openhab/userdata/etc

I have 1.0.8 installed

java version "1.8.0_111"
Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
Java HotSpot(TM) Client VM (build 25.111-b14, mixed mode)

The important number is the number behind 1.8.0: should be not lower than 101

My bad.

I have 1.8.0_65 :blush:

How do I upgrade to the latest version? When I run apt-get update/upgrade it doesn’t update Java…

To clarify, I’m running Raspbian (Jessie) on a RPi 3

Ok, managed to (manually) install 1.8.0_111. Here’s how: http://www.rpiblog.com/2014/03/installing-oracle-jdk-8-on-raspberry-pi.html

Thanks for your help @sihui, you nailed it!

1 Like