[SOLVED] Danalock V3 - Z-Wave

Hi all,
i finaly managed to find some time; With the how to from Nico (thanks btw) i was at least able to find the lock. But - my fibaro and my danalock shows as ‘Unknown Device’ or as 'The device initialisation is not complete.'
Any suggestions (i am actually using 2.1 stable)?


If anyone feels like updating the docs on GH to improve information on this, please feel free :slight_smile: .

Thank you sir! I got my DanaLock v3 included to my Razberry2 z-wave module!

I might be wrong but from what ive read during last hours of googling for clues on how to get the Z-wave test binding to work is that it won’t work without performing this manual inclusion ( feature:install openhab-transport-serial ) in the Openhab-console (karaf).
Btw. This is only necessary for bindings running from the shared addons folder and not for UI installed bindings!

I’ve talked with the German Danalock support: The issue with the open password has been solved and they recommend to use the new app “Danalock Deutschland” (so called in Germany) or “Danalock Premium” (so called in other european countries). The security of the V3 model has been improved as well (e.g. it uses a higher encryption). So the results of this Def Con presentation don’t refer to the Danalock V3 and the current app versions.

1 Like

I’ve updated my snapshot openhab to the latest snapshot, but when adding Danalock V3-BTZE I’ve got this in the logs. Do I need to remove all Z-Wave devices including the controller?

As it’s #1221 it should have the security layer included, but maybe some specific steps, not covered in updating docs, are required.

15:33:44.537 [INFO ] [ommandclass.ZWaveSecurityCommandClass] - NODE 17: setupNetworkKey useSchemeZero=false
15:33:44.582 [WARN ] [otocol.commandclass.ZWaveCommandClass] - NODE 17: Unsupported command class COMMAND_CLASS_SECURITY_2
15:33:44.583 [WARN ] [otocol.commandclass.ZWaveCommandClass] - NODE 17: Unsupported command class COMMAND_CLASS_TRANSPORT_SERVICE
15:33:44.589 [INFO ] [ig.discovery.internal.PersistentInbox] - Added new thing 'zwave:device:099cd287:node17' to inbox.
15:33:44.589 [INFO ] [smarthome.event.InboxAddedEvent      ] - Discovery Resultwith UID 'zwave:device:099cd287:node17' has been added.
15:33:44.591 [INFO ] [smarthome.event.BindingEvent         ] - org.openhab.binding.zwave.event.BindingEvent@153c1bc
15:33:44.591 [INFO ] [ommandclass.ZWaveSecurityCommandClass] - NODE 17: setupNetworkKey useSchemeZero=true
15:33:44.593 [INFO ] [ommandclass.ZWaveSecurityCommandClass] - NODE 17: Using Scheme0 Network Key for Key Exchange since we are in inclusion mode.
15:33:44.595 [WARN ] [erialmessage.IdentifyNodeMessageClass] - Got IdentifyNodeMessage without request, ignoring. Last message was SendData.
15:33:56.658 [INFO ] [ecurityCommandClassWithInitialization] - NODE 17: SettingNetwork Key to real key after SECURITY_NETWORK_KEY_SET
15:33:56.659 [INFO ] [ommandclass.ZWaveSecurityCommandClass] - NODE 17: setupNetworkKey useSchemeZero=false
15:34:18.613 [INFO ] [smarthome.event.InboxRemovedEvent    ] - Discovery Resultwith UID 'zwave:device:099cd287:node17' has been removed.
15:34:18.625 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zwave:device:099cd287:node17' changed from UNINITIALIZED to INITIALIZING
15:34:18.626 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zwave:device:099cd287:node17' changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controlleris offline
15:34:18.628 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zwave:device:099cd287:node17' changed from OFFLINE (BRIDGE_OFFLINE):Controller is offline to ONLINE
15:34:18.633 [INFO ] [smarthome.event.ThingUpdatedEvent    ] - Thing 'zwave:device:099cd287:node17' has been updated.
15:34:18.634 [INFO ] [smarthome.event.ThingUpdatedEvent    ] - Thing 'zwave:device:099cd287:node17' has been updated.

It looks like you’re using the master branch which doesn’t support security - please try the development version -:

Thanks for the swift reply. So the version with security isn’t still even in the snapshot version?

Yes - you need to use the version referenced above at this time.

I was able to get it working. But I had to make some minor changes because of a number of Z-Wave items in my installation to reduce manual work. It’s also a bit detailed. It’s Windows installation.

  1. Screenshot all Z-Wave items with corresponding Node numbers
  2. Delete all Zwave Things using PaperUI (PaperUI preserves items under the deleted thing)
  3. Uninstall the Zwave binding using an OH2 shell with bundle:list getting the number of the Z-Wave bundle, then bundle:stop NUMBER and finally bundle:uninstall NUMBER. I’ve must do this because HABmin nor PaperUI didn’t uninstall it after clicking on uninstall.
  4. Stop OH2
  5. Check if the z-wave bundle isn’t listed in addons.cfg to be installed after start
  6. Copy the JAR file to /openhab2/addons folder.
  7. Start OH2.
  8. The binding was automatically installed
  9. Check if right version of Z-Wave is installed via shell command bundle:list I’m running snapshot 2.2. and z-wave was 2.3. If you have snapshot 2.3 I have no idea how to check the right version.
  10. Open PaperUI and search for new things, add them - PaperUI conveniently asks for Thing name before adding it
  11. When you preserved exact naming of things, the channels will be connected automatically
  12. When you’re done you can go to HABmin, go to things, you should see your z-wave devices adding and configuring it, it but it took some time and looked like errors
  13. If you had the lock added before you need to exclude it from the Z-Wave network
  14. Then you need to do inclusion within HABmin only
  15. Start Z-Wave inclusion by pressing the button with Magnifier and +
  16. Press the button once on Danalock V3
  17. The HABmin should found the lock
  18. Add it. As it’s battery powered it can take some time to recognize it

Just a question:Is it included in 2.2 standard Z-Wave distribution?

Because - i did find it - but it is not able to recognize it as Danalock;

No - you need to use the version described a couple of posts above.

Hi Chris,
is there a plan to make the Danalock V3 support part of the official release?

Is the question specific to this lock? The binding will be merged into master at some stage, but I’m not sure what needs to be done specifically for the Danalock?

Happy to confirm that Danalock V3 works perfectly under the experimental binding

1 Like

Hi Chris,
sorry, my question was misleading.
I want to know when the new version of the ZWave binding (which provides the Support for Danalock V3) is officially released.

Thanks for your help.

hi, i’m still struggling with install and configure danalock.

I have openhab2.2 on windows. I paired successfully danalock with openhab, but the device got recognized as unkown device. so I’m not able to add items to a channel via paperui.

after that I read this thread and found another jar file. so uninstall zwave binding and installed new jar zwave binding. but the result is the same. adding new danalock as thing and still unknown device.

any idea what I’m doing wrong?

it is a bit flakey - try excluding, hard resetting the danalock and then re-pairing.

I get the best results in this order:

  1. bluetooth pair
  2. hard reset danalock
  3. zwave pair
  4. if pairing fails with “unknown device”, then exclude, hard reset, repair.


I would also recommend to use the most recent binding (from the last 2 days) as there was a bug fixed relating to secure inclusion that can cause problems with some devices.

thanks - will report back



I just did all steps again with new jar. The device got recognized now and I can manage it via openHab / zwave.


edit: one thing: does the battery level work? it shows me 0%