[SOLVED] Danalock V3 - Z-Wave

It didn’t securely include, bit it did try (not that that means too much given it failed :wink: ). I would exclude and try again (the problem with security is any failure means you need to start from the beginning).

ohhhh, took a little longer than I would expect, but did manage. Had some hassle when excluding through habmin since there is no much visual feedback on what’s going on. For Inclusion preffered PaperUI since at least there is a spinning binding icon while in inclusion mode. Also the distance between stick and the lock probably was too long, had to find longer usb cable (only later realized could have easily unmounted the lock from door).

Anyways, long story short - I have it!!!

Can lock and unlock it and receive the state changes when locked from phone.
Battery level seems to be wrong - showing 0%, but did not have more time to debug/check.
Would have expected from Danalock to receive also username together with the state change notification, but it is not binding issue, I guess :slight_smile:

Thank You so much, @chris, for the great work, support and patient with me using wrong sources :smiley: Let me know if there is anything I can do to help with further testing of the binding.

HABmin actually has more feedback than PaperUI as it provides some popup notifications on progress. This is especially true for inclusion - HABmin will give you progress notifications showing when inclusion starts/stops, when a node is found, and most importantly if the secure inclusion works or not. This isn’t available in PaperUI.

Anyway, glad it’s working :slight_smile:

1 Like

good to hear/learn it. It might be my problem - since the popus are not persistant, they disappear … and I’m on a slow berry - not staring carefully enough on the screen. My pi3 is coming in this week, will switch over with fresh reinstall and try to do it purely from habmin. I know it will be way better, faster … and easier this time!:))

True - I guess I could make them longer, or even persistent (click to remove) which is done for error notifications but not normal notifications. The whole process only takes a maximum of 45 seconds though (inclusion is only enabled for 30 seconds, and secure include must complete within 15 seconds of the inclusion completion). Normally it’s a lot less than this though so you shouldn’t have to stare at the screen for too long :wink: .

for me it just took some time until the lock reported the Battery level.
what i noticed is the battery consumption seems to be crazy. original batteries which came with the lock where gone in only one week, was told that they most likely where not full any longer.
added new one 1 week ago and are again down to 91% :frowning:

also i noticed now that by some reasons the lock is not reporting the open/close status always via Z-Wave

playing with the new pi3. feeling like a pro!:slight_smile:
Burn new image, stayed on the stable release (even did not switch to snapshot), just copied over Chris .jar to the /usr/share/openhab2/addons and, if doing with clean stick - starting inclusion from HABmin, pin’ing on the Danalock switch and all good.

Interesting, that exclusion did not exactly work for me. With the fresh setup (+plus latest zwave) the previous Danalock node was coming in as unknown. So I selected my stick in the HABmin, did click on Exclude devices, then “pin” on the lock and it ended up switching over to inclusion mode and not removing the lock. At some moment went to Discovery/Inclusion + pin at lock and it was securely added. So I had both - the recognized Danalock and the unknown lock from previous life (which I could not get rid off). Unplugged stick, “manually” excluded, plugged back. Observed USB port number change:), but other than that worked as a charm! Fantastic!

not sure if I will go with the Danalock (just to make people aware)

which was done w v2 … I hope that’s what v3 addresses … hope:)

Great work. On the weekend i‘ll retest everything as i‘d no Time.
I’ll keep you posted what my results will be.

I’d (@jay_ar) twittered with Danalock support about that and they said it was never really an issue/thing - I mean besides the open password from the slides - I did not see any issue. Let’s say - I’m a bit sceptical about that ‘finding’.

Also nobody on the net reproduced this ‘flaw’ as far as I’m aware…
And - it’s about v2 and we are talking here about v3.

Still the question what flaws come with the new ZWave version.

not sure if I understood the video well, but it is about the app they decompiled?!

is the same app used on v2 and v3 or are there different ones?

If you are really want to know more - you may want to read the slides:

In sum : everything is hackable - but from a point of view of a lockpicker - it is “overkill” to go the technical way and not just to use a drilling machine.
just my 2 cents…

1 Like

ok. did found some time today.
did install the october-version - installed it via bundle:… started a scan - but
[WARN ] [zwave.discovery.ZWaveDiscoveryService] - NODE 2: Device discovery could not resolve to a thingType! 7FFFFFFF:7FFFFFFF:7FFFFFFF::0.0

But: i did execute a firmware update on the lock. maybe this is the issue know?

openhab> bundle:list | grep ZWave                                                                                                                                                              
15:48:03 229 │ Active   │  80 │     │ ZWave Binding

I will try later with some more details…

oh, I hate that 7FFFFFF message … was fighting w it few nights :smiley:
in my case the problem was:
using wrong binding (not the 10-24 dev version from Chris link;
and not discovering/including device through HABmin interface (e.g. in case if including to the controller externally and then adding controller to raspberry would not work due to security staff).

(and I also have latest fw on the lock … well, the version that was available 17d ago )

I´m a FHEM user - new to OpenHab 2 AND Z-Wave.
I installed Obenhabian and Z-Wave Me Stick. Found Thing “Danalock” but status is “unknown”.
What do I have to update where to get it connected working?

When will the lock find its way to the official OpenHAB2 Version? I don´t want to spend my time debugging nightlies oder special dev versions, as this is an integral part of my families smart home. Not meant to be rude, btw!


Nico, first thing - make sure you are using this Z-Wave binding:

This was my recipe for getting it working
Download the jar from very first post, first line: “The latest version of the test binding … is here”.
Exclude the existing Danalock from the stick.
Uninstall existing ZWave binding.
Copy over this jar to your usr/share/openhab2/addons directory
restart openhab (just to keep things clean)
Start discovery of the Lock from HABmin interface (not from the stick) - by clicking
When Danalock thing discovered- add the thing. Assign item to channel, live with it :slight_smile:
fingers crossed!:slight_smile:

Perfect info. Will try and report back.

Looks promising - in case somebody else needs the info here is how it seems to work:

  1. Delete all Zwave Things from Habmin.
  2. Uninstall the Zwave binding from Habmin. - You will NOT reinstall it.
  3. Stop OH2
  4. Copy the JAR file to your /usr/share/openhab2/addons folder.
  5. Start OH2.
  6. log into Karaf ie… ssh openhab@localhost -p 8101 password is habopen
  7. Start the zwave binding with: bundle:start org.openhab.binding.zwave
  8. If get an error, you need to install the serial binding first: feature:install openhab-transport-serial
  9. Now got back to Habmin, and Readd a Zwave Controller. Do NOT re-install the 2.0 Zwave Binding.
  10. Set your USB port and rescan for devices.

I got my danalock v3 working thanks to this post.
One note is that I had to exclude and include all my zwave devices to make it to work after the new zwave binding.