[SOLVED] Dimmer not working in OH2 but works in KNXController android app?

Hi all,
I have a strange problem. I have been trying to integrate KNX fan coil controller (for HVAC cooling system) for a week now in OH2. Then I just tried to add it as a dimmer to this small old android app called KNXController and it works perfectly. When you slide it all the way it runs fan full speed (sends 100%, if you slide all the way left,0% it turns off the fan. up to 33% is the 1st speed of the fan, up to 66% second speed.

When I tried to configure the same device as dimmer with DPT 5.001 (exactly the same as on android app) and added it as a slider in sitemap, it just doesn’t work.
[DEBUG] [.internal.handler.DeviceThingHandler] - None of the configured GAs on channel ‘knx:device:bridge:generic:ACLiving1’ could handle the command ‘41.0’ of type ‘PercentType’

How come I cannot achieve the same functionality that works in android app that connects to the same KNX gateway as OH2, any ideas…??
Just to mention that on the same system (on RPI) I’m controlling all the lights in the house via the same knx bus, so my openhab2 installation is working OK.

I have seen people had issues with using DPT twice, but that’s not the case in my setup…

Type dimmer : ACLiving1 “Temperature” [ ga=“5.001:1/5/48+<1/5/49” ]

Dimmer ACLiving1 “ACLiving1 [%d %%]” { channel=“knx:device:bridge:generic:ACLiving1” }

Slider item=ACLiving1

not sure if this is the correct category for the issue…


I think you want position= for a dimmer channel

thank you so much man, works perfectly :grinning: