[SOLVED] Discourse forum app for iOS and Android

I just discovered this and wanted to share as I didn’t see this anywhere else on the forum. Discourse, the software that powers this forum, offers both iOS and Android apps. They add notifications and make it easier to keep up with the forum on the go.

It’s easy to add the openHAB community as well as other Discourse forums like Particle, Fritzing, etc.

iOS:

Android:

1 Like

I am obviously being dense, but what URL did you use to add the openHAB forums?

1 Like

I believe community.openhab.org should work- let me know if it doesn’t.

Unfortunately not - says community.openhab.org was not found!.

Strange. I removed and re-added openHAB; it found it when I searched for community.openhab.org

Are you using iOS or Android?

Android

Very strange, was able to find and connect to community.openenergymonitor.org

I use iOS so I don’t know if anything specific to Android might be in play… I assume you tried usual troubleshooting techniques including restarting the app and even reinstalling it?

@ThomDietrich, I noticed you did some work on a Discourse plugin; do you have any ideas?

https://community.openhab.org and confirming the authorization request to my forum account worked for me on Android.

Edit: the only benefit I can see at the moment are the notifications, everything else looks like the mobile view on Android Chrome browser …

Just wanted to verify that it doesn’t work for me neither. Tested the app on Android 7.0, I get the same result as @ben_jones12. Tried both with and without https://

1 Like

@sihui I, for one, prefer a separate app than having to keep track of tabs open in my browser. May be of limited use to others, but I find it handy.

@DanielMalmgren @ben_jones12 Perhaps someone experiencing the issue should bring this to the attention of someone over at Discourse? They have a forum too.

Good point. Since it seems to work with other forums though question is if this is related to some specific setting in this forum.

I’ll try to get the time for getting a logcat of this today, might tell us more about what is really happening…

Just confirming that it works for me as well.
On Android 7.1.2

1 Like

I’ve now ploughed through some thousand lines of log and I can’t say I’m any wiser. It seems the app is using ReactNativeJS which gives the error “ReactNativeJS: [TypeError: Network request failed]”. Not much more information than that.

Can’t really understand why it works for some people and not for some. Guess I’ll simply have to stick with the browser version.

Thanks for having a look. Back to the browser for me too then.

Hi,

i’ve used the Android Discourse app for quite a time on my old phone. When switching to a new one with Android 7 i realizied, that the app isn’t able to connect to community.openhab.org. I went to the support forum on meta.discourse.org and got the advice that there is a fix in the current Discourse release which deals with this issue.

The fix is in this commit:

Maybe some kind administrator could install this?

kind regards,

Christoph

Same here.

+1

@belovictor, @hmerk, @digitaldan: It would be very kind, if one of you could have a look at this…

kind regards,

Christoph

Hi,

just tested (on Samsung Galaxy S8) and found, that the Android app is working again!

kind regards,

Christoph

1 Like

Confirmed (Android 7.0) :+1: