[SOLVED] Don't know how to install OmniLink1 module in OpenHAB2

I’m extremely new to all this - but I’ve not been able to figure out how to install the OmniLink1 connector within OpenHAB on Raspberry Pi.

I’ve gotten into the OpenHAB console, but when I list modules, that one isn’t listed, yet it is listed in the Add-ons section of this website…

Any help would be greatly appreciated.

That is an OpenHAB 1 binding. Since it does not show by default, it must be a legacy binding. You need to tell OH to include Legacy 1.x Bindings.

1 Like

I’m not sure why you would want to use the version 1 omnilink binding. There is an omnilink 2 binding in the Market Place. Enable the Eclipse IoT Market in the Misc. section of the addon’s and the latest version of the omnilink binding will show up under Bindings.

1 Like

I didn’t realize there was a v2. When I went to the Addons section, all I found was V1. I’d love to use the modern one and will try what you suggest. THANKS!!! Any idea where documentation would be on that module? Just added and not seeing where I can configure it to link to the OmniPro panel. I ended up finding how to do it with the ADD MANUALLY function, but is there some documentation on the module somewhere? Thanks.

And Bruce, the only reason I didn’t use that is because the description indicates that it won’t show a v1 module unless there’s a corresponding v2 module.

Hmmm. Wrong description for sure. I know PaperUI is being deprecated soon anyway. From what I understand there is no developer who can support it well.

What is the recommended interface instead, so I can go ahead and load it and just get used to it now. :slight_smile:

Purely my guess is that the ESH bindings will likely be moved to OpenHAB.
I have not seen a statement from @Kai about that though.

There is no such thing as “ESH bindings” - I guess you mean bindings that are available in the IoT Marketplace? If so, they cannot be “moved to openHAB” as their code is neither at ESH nor at openHAB repos.

For many bindings in the Marketplace, there is an open pull request at openhab2-addons waiting to be merged - once this is done, there is no need to have it in the Marketplace anymore.

Wrt Omnilink, I have just checked: It seems to be not ready yet and - hopefully - still being worked on, see https://github.com/openhab/openhab2-addons/pull/5508.

1 Like

Thank you for the explanation.
I assume any documentation would transition too.

So this is funny (not really). While troubleshooting an issue on something else, I cleared cache, and ever since, the OmniLink module keeps uninstalling itself. When I search, I only see the OmniLink v1 module. I’ve removed/readded the marketplace, but still, only the v1 of the Omnilink module shows up. It keeps going offline, so it’s certainly not stable, but I can no longer find the v2 of that module.


I don’t use the Marketplace. I have had similar results during upgrades. I download the jar file directly from the source and place in my addons folder.

Here’s the link:

1 Like

I ended up wiping the SD card, reimaging, and switching to SNAPSHOT. Been far more stable since.

1 Like