[SOLVED] eBus Binding not installing

Hi - fairly new to OpenHab, trying to set up my newly-bought esera eBus --> USB converter but am having trouble getting OpenHab to see the new binding.

I’ve gone to PaperUI, found the eBus binding, clicked INSTALL - which it completes without issue. I go to my Inbox, click Add Item, but the eBus binding does not appear. However, if I try the same for another Binding (like Network) then that bindings appears and I can add an item against it. Likewise, if I go to Confguration --> Bindings, the eBus binding I’ve just installed is nowhere to be seen.

I’ve connected the eBus interface to my (Vaillant) boiler and it’s chatting away merrily. That interface is plugged into my RPi (v3) via USB and I’ve enabled Serial ports via openhabian-config.

Anyone any ideas? I’ve rebooted several times… Newly-installed OpenHab BTW… from the pre-packaged download just this weekend, so all-up-to-date.

In openhabian-config did you run fix permissions option? This will make sure the user is part of dialout, tty, and bluetooth group.

Also anything about binding in logs when restarting? Check that you have the binding via the console. sudo openhab-cli console then use bundle:list option to show all your installed bindings. Look to see that eBus is installed and Active.

EDIT: More on the console can be found in doc’s here. Check some of the other usefull commands that can be ran from console to help with binding issues.

Hi H102 - thanks for the fast response. I ran the fix permissions (no change). I did the bundle:list - and it wasn’t there…! So I checked the logs and yep, there’s an issue. It says “Unexpected problem updating configuration org.openhab.ebus. No properties in openhab.cfg set”. I’ll take a closer look now. I set the ebus.cfg file up originally - didn’t realise there was more config…

Update: Just checked for that openhab.cfg file and can’t locate it. Am using sudo find -name openhab.cfg but no matches come back. Any ideas?

1 Like

Try using the console to uninstall then reinstall the binding. You can also use console to resolve issues…see the link I posted above for all the commands.

I’ll get back to you on the openhab.cfg file but that is something you shouldn’t have to modify.

Not sure what binding version your running but here is another link you may find helpful https://github.com/openhab/openhab1-addons/wiki/eBus-Binding#logging

Hi - I checked bundle:list once again and it’s actually in there (right at the end) and it’s showing ACTIVE. So I guess that’s good…

I’ve added an increased level of DEBUG and strangely things look happier now in the log in that (I think) I can see data coming through the serial interface:

2019-11-18 16:51:21.280 [DEBUG] [inding.ebus.internal.parser.Analyses] - 10 08 B5 11 01 01 89 00 09 76 6C 00 80 FF FF 01 00 FF 8A 00 AA
2019-11-18 16:51:21.283 [DEBUG] [inding.ebus.internal.parser.Analyses] - >>> Unknown ----------------------------------------

So whilst that’s good, I still don’t see the binding appear in my inbox after a search like I do the other bindings (like the ‘Network’ binding) so I can’t ‘discover’ the new device and continue my config of it.

Slow progress, but progress all the same…

Any pointers on what to tackle next to get this working?

Update on the above… Seems it’s working but given it’s a 1.13 version (not 2.?) then the ‘discovery’ bit doesn’t work in PaperUI as I’d expected - at least that’s my understanding. The issue was that once I’d installed the Binding I wasn’t seeing anything following Discovery / Inbox refresh.

I’ve noticed someone out there has developed a 2.? binding for eBus so will try and find out how to install it as the 1.13 binding isn’t doing what I’d hoped and I’m running out of ideas on how to get the values (from my boiler) up onto HabPanel.

I found a 1.14.0. Snapshot version (last modified 13 Oct 2019) but didn’t see a version 2. Here’s the link https://openhab.jfrog.io/openhab/libs-pullrequest-local/org/openhab/binding/org.openhab.binding.ebus/1.14.0-SNAPSHOT/

Stop OH and place the jar file in /usr/share/openhab2/addons directory then restart. May as well clean the cache while you have OH stopped.

If I stumble across a 2. version I’ll post it here.