[SOLVED] Enocean binding and windows, no go?

Tags: #<Tag:0x00007f7459e30c18> #<Tag:0x00007f7459e30b00> #<Tag:0x00007f7459e30a10>

Hey Ladies and Gentlemen

Complete noob here. Just trying to set up some testing to learn openhab but can’t even get the basics going.

Had some old enocean equipment at work so I figured that was a good start to test openhab. Bought an enocean usb300 but I can’t seem to get it into openhab. It seems to work in the system (windows 10), I’ve installed dolphinview from enocean and it can see pushbutton events in the log of that program (when I push the button) and it connects to usb300.

From what I understand the usb device should be automatically picked up by openhab?? But from what I can see it hasn’t (or I’m just to noob to understand it). When I scan for things on the binding (and pushes a button) nothing happens.

What am I missing, I can’t find any config file for enocean either (should be one if I’m not mistaken) and log file doesn’t show anything more than just that the binding is installed.

Please help, I’ve tried to search for info but I can’t find anything regarding windows and enocean.

thank you
Mikael

My system:
Win 10 pro
Openhab 2.4 (downloaded it the other day)
Oracle java 8 211 (downloaded it yesterday)
Enocean binding 2.4 (installed from within openhab)

Hello Mikael,

auto discovery of USB300 just works in Linux. There exists no API to discover USB devices in Windows. So you have to add the gateway manually and choose the right COM port. The binding definitely works under Windows as I have developed it under Windows 10. However I would recommend to use the 2.5 snapshot version of openhab as the 2.4 binding version has some major bugs.

Best regards
Daniel

Daniel, thank you for your reply.

That was a big detail that i missed. and that explains why it doesent work. ill try the 2.5 snapshot.

thank you

mikael

Hi again.

When manually adding. Do I have to create any config files or edit an existing one.

Going to try this tonight when I get home.

Thank you.
Mikael

I think you may need to take into account that other software and openHAB cannot “share” a USB device. You may need to stop or disable this dolphinview thing.

Yes of course. That was just installed for testing. It won’t run when openhab runs.

/Mikael

Hi Mikael,

for a simple test you can just add it manually in openhab, no need to add/edit config files.

@rossko57: Good point!

Best regards
Daniel

Daniel

Did you manage to get it working?

Regards

Daniel

Oops. Sorry that I didn’t get back. Yes I got the binding to work and I found one thing. So yes it works. Haven’t put much time in to it afterwards. Had to manually add the USB device to the config file.

Than you.

/Micke

Hi Daniel,
I have no problems running the binding on windows, too. As I said discovery of USB gateway does not work. However after adding this thing manually other devices should get discovered through the differn teach in processes.
Tested on Win10, openhab 2.5 shapshot #1649.

Best regards
Daniel

Managed to get it working as well. The only thing I struggling with now is the update delay in the temp sensors. It takes about 20min to update?

Thanks for the help!

HI @Daniel101 ,

to save energy most sensors just send a new message after a certain threshold for temperature change has passed. My thermokon for example have a wake up interval of 100 seconds. If temperature has changed approx 0.8K a message is send otherwise not. However at least after 1000 seconds a message with the current status is send. So 20 minutes is a realistic value for your sensors. Which sensors do you own?

Best regards
Daniel