[SOLVED] Error 404 on all pages in paper ui


i’ve recently upgraded to snapshot 2.2.0 #1017 of openhab. Since then I receive error 404 on all pages in pager ui on the on the lower corner on the right side of the screen.
Also habmin gives error messages like “der Servier ist offline” or “Fehlr beim Laden der Thing liste”.

I was using openhab 2.2.0 snapshots before without any problems.
Openhab has already been restarted several times w/o success.

Does anyone have a idea, what is wrong.

Thanks a lot.


Stop OH.

Delete the contents of /var/lib/openhab2/cache and /var/lib/openhab2/tmp.

Restart OH.

See if that fixes it.

yes, that’s it. Thanks a lot!


I just experienced the same issue. When clicking on PaperUI/Configuration/Things, all my stuff will be shown as “online”. However, when I click on any device, the message “Error: 404 - Not found” pops up. And in fact, openHAB is not working anymore. No matter what switch on my sitemap I am pressing, there is no result, eventhough in the log everything behaves normal and as expected. When SSH into my RPi and checking the OH status, everything seems to be fine and active.

I followed these instructions and completely deleted the content of these folders (including sub-folders). However, that didn’t change anything.
I am on openHABian, 2.1 stable.

I am bit confused and worried about what is going on…

Look in the /var/lib/openhab2/jsondb and look in the files there, in particular, org.eclipse.smarthome.core.thing.Thing.json. Are your missing Things listed?

If not, somehow your Things database became corrupted. With some luck, there is a backup in the backups folder there that you can copy over and recover all or most of your Things.

Hey Rich, I found the mistake. When I rebooted my RPi, my Z-Wave stick and my 433Mhz cul got assigned different device numbers (tty*). I had to boot the RPi with only the Z-Wave stick attached to it and subsequently add the the 433 MHz stick. Now everything is working fine again.

I do remember that I identified the gateway sticks by serial when I used FHEM. In that way it doesn’t matter what tty* a stick get assigned. That should be possible in OH2 as well?

With ls -l /dev/serial/by-id I do see the serials. Can’t I simply use these ones to identify the port?

[07:44:08] openhabian@openHABianPi:/dev$ ls -l /dev/serial/by-id
total 0
lrwxrwxrwx 1 root root 13 Sep 27 06:23 usb-0658_0200-if00 -> ../../ttyACM0
lrwxrwxrwx 1 root root 13 Sep 27 06:32 usb-busware.de_CUL433-if00 -> ../../ttyACM1
[07:44:42] openhabian@openHABianPi:/dev$

Give it a try and find out. If not search Google for how to make sure they come up on the same port every time. There have been some postings on the forum as well, but I couldn’t find them.

I found that simple solution, which is perfectly working on my side.

I got this issue is there a fix

If you have the same issue as a 3 year old version of OpenHAB it is well last time to upgrade to the latest stable version.

If you are not running a 3 year old version you have a different issue and should start a new thread with enough information for someone here to assist.

im on the new version

1 Like

You then need to open anew topic with the details of your system, any log errors, and what you have tried to troubleshoot the issue.

This may have similar symptoms but is bnot the same issue.