[SOLVED] [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing all bindings

What are you running OH on and how did you install OH?

Since the error is related to your binding installs did you use the addons.cfg file or PaperUI to install all the bindings?

Also see this issue github.

Thanks for the quick answer and good to hear I don’t seem to be alone with my error. I am on openHABian - Hassle-free openHAB Setup. Bindings installed with PaperUI.

I haven’t read thru the issue on git but it may help to delete /var/lib/openhab2/config/org/openhab/addons.config so it is regenerated with correct content. Please note that by deleting this file you will have to reinstall all your binding again (b/c they were installed via PaperUI). FYI If you have them installed in the addons.cfg file then after a restart OH will automatically reinstall the listed bindings.

I deleted the file and did a restart. No progress unfortuntely. Attached screenshot show my options.

I can’t read the error log, print to small.:smile:

You can alway’s roll back to an earlier stable version of OH with.

sudo apt-get update
apt-cache showpkg openhab2

Pick the version you want then fill in the xxxx with the version number.

sudo apt-get install openhab2=2.xxxx

Back in business. Thanks. For whatever reason I already went back earlier today without success. Now it worked after reinstalling all bindings.

@frankie.delure Glad to see your back up and running.:+1:

Sometimes when changing versions you have to delete /var/lib/openhab2/config/org/openhab/addons.config and restart so OH can install everything from a clean slate.

If you would please mark the topic solved by clicking the square box (lower right corner) on the post that provided the solution. This helps other’s with a similar issue find a quick solution.


1 Like

My commands to Force reinstall were:

sudo apt-get -o Dpkg::Options::="--force-confask" -o Dpkg::Options::="--force-confmiss" install --reinstall openhab2=2.5.0~S1512-1
sudo apt-get -o Dpkg::Options::="--force-confask" -o Dpkg::Options::="--force-confmiss" install --reinstall openhab2-addons=2.5.0~S1512-1

I also had to get back to the #1512 addons. Otherwise the error still occurred.
#1519 doesn’t show this error anymore.

1 Like

I had the same problems after OH2 build #1518 upgrade - no addons and scheduler errors on startup. I’ve stopped OH2, removed /var/lib/openhab2/config/org/openhab/addons.config and upgraded OH2 (yesterday #1521) with no issues and additional commands.

Firstly this is my first post so I would like to say thank you to all that contribute, it has helped me immensely. I have been playing around as a noob for some time now, I have a very limited coding background and wanted to put something here as someone starting out might trip up where I did.

This all started when I updated my network adaptor (/etc/network/interfaces) and failed to add dns-nameservers. The Pi was fine on my network internally but obviously was powerless when trying to discover the outside world, page 1 mistake on my part for not checking this 1st when noticing my cloud service had gone wonky. Anyway before I discovered this I had managed to break everything else and couldn’t install any releases. Once I fixed the DNS I could roll version and restore a backup.

If using ZRAM, RTFM! I didn’t and it cost me a day. When rolling back/upgrading/cleaning the cache on ZRAM.

My file system was forced to Read-Only in the end “EXT4-fs error (device zram1): ext4_journal_check_start:61: Detected aborted journal” but you can still follow these steps to recover.

  1. stop openHAB2: sudo systemctl stop openhab2
  2. clear the cache from ZRAM: sudo rm -rf /var/lib/openhab2/tmp/* /var/lib/openhab2/tmp/.??* /var/lib/openhab2/cache/*
  3. stop ZRAM to make it sync to disk (notably the Karaf-generated files in /var/lib/openhab2/cache and …/tmp): sudo systemctl stop zram-config
  4. upgrade OH. Don’t reboot (remember automatic startup of ZRAM and OH at boot time). The upgrade process clears the cache so you don’t need step 5. Then again, to double check does not hurt.
  5. clear the cache from disk: `sudo rm -rf /var/lib/openhab2/tmp/* /var/lib/openhab2/tmp/.??* /var/lib/openhab2/cache/*.
  6. start openHAB2 again: sudo systemctl start openhab2
  7. after some minutes of runtime, stop openHAB2 again: sudo systemctl stop openhab2
  8. if required , edit /etc/ztab and assign more RAM to the affected share while you can.
  9. start ZRAM again: sudo systemctl start zram-config
  10. start openHAB2 again: sudo systemctl start openhab2

I hope this saves someone some time


Thanks for publicly admitting. Most people aren’t that bold.

BTW there’s an upcoming change in openHABian, ZRAM will no longer include the cache but swap, logs and /var/lib/openhab2/persistence only.
You can also edit /etc/ztab to accomplish that yourself.

PS: and it’s actually If using OH, RTFM!

Thanks Markus, I’m from an engineering background so mistakes are sometimes required to learn. mistake>learn>move_on, the more we admit the quicker development happens!

Thanks for your work on ZRAM with OH I have been using it since the start of my OH quest with no problems (only on my part). Nice to hear about changes I will continue my exploration.

I also had this read-only filesystem error and failures from core.karaf saying it wouldn’t install bindings and Paper UI wouldn’t start, etc…all kinds of problems. Was going to revert to backup but turns out the overall OS update I did via openhab-config turned ZRAM OFF. Simple fix to turn it back on and reboot but damn, took me a few hours to play around until i realized in the release notes ZRAM is OPTIONAL by default.


Version I use
I use Openhab 2.5.12.-1 and all was working perfectly but now my error log is full of

Error I have

[ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-snmp1, openhab-action-mqtt, openhab-binding-mqtt1’
And MQTT binding is not working any longer…
=> I still see on the Panel that my mqtt-devices are turned on/off but no MQTT message is sent out
Also homematic binding is not working

What I tried

  • restart OH2 5x
  • emptied chache
  • deleded addon.cfg as proposed somewhere…
  • restart raspi pi4 several times
  • red everywhere , saw that I need to add in addons openhab-addons-2.5.12.kar
  • changed ownership to openhab, gave rw access to all and even execution access
  • went to the homepage and ```
    wget -qO - ‘https://openhab.jfrog.io/artifactory/api/gpg/key/public’ | sudo apt-key add -
    Please HELP
    I do not want to go to version 3 as I need and want mqtt binding 1.1. The hole installation became useless as no mqtt comands are sent out. It seems that the addons are no longer available for download? But why?

What is remote = set to in addons.cfg in /etc/openhab2/services/ is it set to false resp. put into a comment ? As far as I can see version 1 bindings are not included in the openhab-addons-2.5.12.kar file.

addons.cfg I put in:
remote = false

I red somewhere this needs to be added

Can it be that mqtt v1 binding is not in the .kar file I downloaded?

Thanks Wolfgang
So anyone knows how I can add the 1 bindings to the kar files? To use a “stable” version that is not stable and moving is kinda useless… :frowning:

The legacy add-ons are part of this openhab-addons-legacy-2.5.12.kar file.
Just add it to the /addons directory like that other KAR file. :slight_smile:

1 Like

yeeee! many many thanks!

For others having the same issues

In /etc/openhab2/services/addons.cfg change remote = false
=> Check log file and see how the bindings get installed