[SOLVED] Error loading dashboard list

I have setup openhab2 on my raspberry pi and am having trouble getting habmin2 up and working

  1. I have the following in my addons directory

    pi@raspberrypi /opt/openhab $ ls -la addons/
    total 4048
    drwxrwxr-x 2 root root 4096 Dec 6 16:10 .
    drwxr-xr-x 12 root root 4096 Dec 6 15:51 …
    -rw-r–r-- 1 root root 81008 Dec 6 14:02 org.openhab.binding.astro-1.8.0-SNAPSHOT.jar
    -rw-r–r-- 1 root root 28738 Dec 6 14:01 org.openhab.binding.hue-1.8.0-SNAPSHOT.jar
    -rw-r–r-- 1 root root 28627 Dec 6 14:01 org.openhab.binding.mqtt-1.8.0-SNAPSHOT.jar
    -rw-r–r-- 1 root root 18345 Dec 6 14:02 org.openhab.binding.wemo-1.8.0-SNAPSHOT.jar
    -rw-r–r-- 1 root root 1619998 Dec 6 14:03 org.openhab.binding.xmbc-1.8.0-SNAPSHOT.jar
    -rw-r–r-- 1 root root 1077403 Dec 6 15:34 org.openhab.binding.zwave-1.7.0.jar
    -rw-r–r-- 1 root root 1189971 Dec 6 14:03 org.openhab.binding.zwave-1.8.0-SNAPSHOT.jar
    -rw-r–r-- 1 root root 29507 Dec 6 16:10 org.openhab.io.habmin-1.7.0-SNAPSHOT.jar
    -rw-r–r-- 1 root root 37385 Dec 6 15:18 org.openhab.ui.habmin_2.0.0.SNAPSHOT-0.0.15.jar
    -rw-rw-r-- 1 root root 126 Dec 4 11:26 README

  2. in my webapps/habmin2 directory i have
    pi@raspberrypi /opt/openhab/webapps/habmin2 $ ls -la
    total 28
    drwxr-xr-x 4 root root 4096 Dec 6 15:52 .
    drwxrwxr-x 6 root root 4096 Dec 6 16:08 …
    drwxr-xr-x 2 root root 4096 Jun 19 23:07 assets
    -rw-r–r-- 1 root root 9407 Jun 19 23:07 index.html
    drwxr-xr-x 5 root root 4096 Jun 19 23:07 languages

  3. I have changred start.sh so that my http:// port is 8081

  4. When i go to i get “error loading dashboard”

any help would be greatly appreciated

I’m pretty sure it causes problems to have two different versions of the same binding in your addon folder: delete org.openhab.binding.zwave-1.7.0.jar and org.openhab.io.habmin-1.7.0-SNAPSHOT.jar and try again.

Good luck.

I thought you needed org.openhab.binding.zwave-1.7.0.jar in the addons folder in order to run habmin2?

I placed the org.openhab.io.habmin-1.7.0-SNAPSHOT.jar in the addons folder as I decided after many attempt to try to use habmin1.

I’ll try that and get back to you.

Sorry, I didn’t see you are on OH2. My suggestion was if you use OH1.
So disregard everything I wrote before :grin:

@sihui Do you know of any guide to setting up Habmin1? as i have just found out that Habmin2 does not allow you to set associations for Zwave so I cant use Hambin1.

It is possible to use Habmin1 with OH2? or do i have to start from scratch and reinstall OH1?

Hmmm, why can’t you setup associations when I am able to do it :innocent:

Go to Configuration … Z-Wave, click on your node and on the right hand side of the browser window you find “Associations”.

[quote=“RetailAssist, post:5, topic:4825, full:true”]
Do you know of any guide to setting up Habmin1? [/quote]

Only what I’ve found here.

Maybe I was reading an old post.

P.s @sihui You have been very helpful to me, and no doubt to others, if i have issues with my HABmin2 do you mind If i come back to you with a couple of questions?

Anytime. And I’m sure I speak for all the other forum members :wink:

Thank you

@sihui Do you mind if I ask what are the contents of your addons folder ?

No problem at all, but keep in mind that I’m on OH Version 1!

pi@raspberrypi2 /usr/share/openhab/addons $ ls

Thank you.

You have your OH installed at /usr/share I have mine installed in /opt/openhab does that matter and if it does not how did you install yours in /usr/share ?

There are two different aproaches to install openhab:

  1. manually (download zip or fetch files via wget) and copy those files to /opt/openhab or

  2. install via apt-get (and get all updates when you update your RPi).

Edit: then your folders are:

service configuration /etc/default/openhab
site configuration /etc/openhab
log files /var/log/openhab
userdata like rrd4j databases /var/lib/openhab
openHAB engine, addons and /webapps folder /usr/share/openhab

For me the apt-get install works better than my manual install before: less java errors, more stable.

I used the manual method using wget, its ok just that some of the github links fail to allow you to download, you get errors such as broken pipes etc.
When you use apt-get are you able to see the folders in finder on the mac.

At the moment all my folders are not showing up in finder so I have to use sudo nano to edit any files i.e. the items file

I don’t have a Mac so I cannot tell you.

By default ssh is enabled on the RPi, so if you don’t need a graphical user interface you could use a ssh client on your Mac to access the RPi.
If you need a GUI you could setup a VNC server.
I use both methods on my Windows PC and it works fine.
In addition to that you also can setup a samba server to access your files through Windows Explorer (I guess that is the “Finder” on a Mac).

@sihui do you know much about zwave based rules and triggering them ?

I have readings coming from my zwave sensor but my rules are not triggering

//* Act on the chnage of temperature - Turn off or on the wemo heater
rule “temperature in”
Item Temperature changed
logInfo(“Temperature”, “******* Temperature change *****”)

temperatureIn = Temperature.state

if (temperatureIn < 21)
// Turn on wemo portable heater
logInfo(“Heater”, “******* Turn ON portable heater ")
// Turn off wemo portable heater
logInfo(“Heater”, "
** Turn OFF portable heater *****”)


// Aeotec Multi Sensor 6 ******************************************************/
Number Temperature “Temperature [%.1f °F]” (multi,multiGraph) {zwave="2:command=SENSOR_MULTILEVEL,sensor_type=1,refresh_i$

Number Humidity “Humidity [%.0f %%]” (multi,multiGraph) {zwave="2:command=SENSOR_MULTILEVEL,sensor_type=5,refresh_in$

Number Luminance “Luminance [%.0f Lux]” (multi) {zwave="2:command=SENSOR_MULTILEVEL,sensor_type=3,refresh_in$

Contact Motion “Motion [MAP(motion.map):%s]” (multi,motion) {zwave="2:command=SENSOR_BINARY,respond_to_basic$

Number Battery “Battery [%d %%]” (multi,battery) {zwave=“2:command=BATTERY,refresh_interval=120”}

– I dont even get the logInfo displayed in the openhab console to tell me that the rule had been triggered

Actually no, I’m a “copy and paste” programmer :grin:

But what I can see from your posted rules is:

Maybe your Item “Temperature” didn’t change at all so that the rule doesn’t get triggered. Take a look in your events.log if you can see any change. If not try

Item Temperature received update

Definitely change
because this is case sensitive.
Last thing I noticed: you don’t have an item configured for “PortableHeater”, so you won’t be able to switch it.

If nothing helps create a switch item “test” without a binding config and display it on your gui.
Put in your rule
Item test changed instead of Item Temperature changed so you are at least able to test the content of your rules further to the bottom.

Good luck.