[SOLVED] Eurotronic Spirit Thermostat Mode numerical after upgrade


I’ve upgraded to OH2 2.5.0 Release build from my earlier 2.4 system and re-added all my zwave devices.

The issue I’m facing right now is that the “Thermostat mode” in Paper-UI is shown as numeric value and not as textual as before.

I’ve also searched in the “Things” settings and items but I’m not able to find something to change that behaviour.

Someone else has as similar problem ?



PaperUI is for configuration not control. Have you created a sitemap file with your items and checked the display in Basic or ClassicUI?

No, I never had a sitemap and in OH2.4 it showed the mode in PaperUI as textual drop-down menu.

Do you use the Spirit T-Wave Thermostate yourself ?

Since there is no developer that can work with the Paper UI it is recommended only for administering openHAB. The Basic UI or HABPanel are recommended for daily operational use.
Since the mobile apps are generally based off the Basic UI sitemaps, most people use the Basic UI.

1 Like

since now I lived under the impression that PaperUI is the successor to BasicUI and should be used by default.

What do you mean with “Since there is no developer that can work with the Paper UI” ?

What makes you think this?

We are trying to help not debate as this info is part of the documentations. Create a sitemap and see what happens. If not then maybe OH 2.4 is better for your purpose.

Here is my understanding of openHAB2 history.

When OH2 started there were some companies interested in using OH in their products. Our developers started Eclipse Smart Home as the OH2 technology base, hoping to attract company participation, OH2 became the free implementation of ESH with some additions.

One company donated the developer resources to develop the Paper UI. It was not completed before the developer abandoned it and they used a technology not familiar with our other developers. OH developers began looking toward other UI options for OH3 and recommended the Paper UI for administration use only.

After several years (2+ I believe) of not getting any company participation, it was decided in January 2019, after 2.5M1 had been released, to merge ESH into OH. 2.5M2 arrived 8 months after M1 with that merge and a completely redesigned build system. That is why 2.5 Stable was no released in the normal 6 month cycle.

Although OH3 has been declared as the next major release, there is also work on a patch release 2.5.1.

Here is the ESH intrgratuon annoincement,

1 Like


From the documentation here :

I really appreciate your help, ask questions to better understand your statements and also didn’t want to start a debate.

The reason I started this thread was that the behaviour was different than before, and I wanted to understand and learn why this happened.

That looks like (another) case of the documentation not being updated. Thank you for showing your source of confusion. I thought you might have been a real early OH2 user.

Thanks Bruce,

somehow I misunderstood all this UI-thing, great info you shared.

So back to the reason I upgraded to OH2.5 -> move everything from PaperUI to config files.


So-so I’d say.
I have a lot of experience in the Linux, networking and security sector.
I also use OH2 for something over 2 years now in my spare time.

So I’m familiar with the concepts but the Basic-UI and sitemap thing never got my attention since OH2 did what it should by PaperUI.

A few months ago I decided to upgrade to the development branch of OH2.5 and it bothered me, that PaperUI was “hiding” it’s configuration on the CLI from me.
So I tried to move my config from PaperUI to config-files, which got stuck by the lack of time.

This needs to be done next. Including creating a sitemap.

Thanks again for all the help.

Sitemaps are not too difficult. If you are moving to text files, I recommend not making text files for Things unless required by the binding. It is usually less error-prone to have them auto generated.

To get back to your real problem :wink:
My Paper UI shows following for the Spirit;

So you should maybe delete the Spirit Thing in Paper UI and search for it again to get the latest XML-file.
In my opinion no matter of UI.

Hope this helps!

1 Like

Good point …

Thanks for getting back on my topic :wink:

That’s how it looked like before.
Let’s see …

ok, I checked it again, re-discovered the thing and also re-installed the zwave binding without a change. The bindung version is (and was) 2.5.0.

The mode is shown as numeric.

Can you do me a favor and check the thing for the “Thermostat mode” type ?

Mine is :

And I think this might be another hint since it’s of type “number”.

Yes of course:

Strange, mine is shown also as number …
I’m also on 2.5 stable.

Following my entry in items file:

Number HeizmodusBuero "HK Büro Modus" {channel="zwave:device:Razberry2:node9:thermostat_mode"}

Unfortunately no further idea :roll_eyes:

Just for reference, I couldn’t solve it.

I tried a lot of things, including

  • thing delete and re-discover
  • binding re-install
  • cache delete (and the above)
  • complete delete of the zwave folder after binding uninstall

nothing gave me the expected result.

So I decided to flash abother SD-Card and installed OH2.5 from scratch.

What should I say …
I got the drop-down menu again without any extra steps.

Looks like the Upgrade from OH2.4 to OH2.5M5 to OH2.5 stable broke something which could not be easily fixed.

Thanks @Bruce_Osborne and @chris4789 for your efforts.

1 Like