[SOLVED] EVERSPRING Flood Sensor stops communicating

Hi all,

Raspberry Pi3, Openhab2.4, AEOTEC GEN5, EVERSPRING Flood Sensor ST812

I have now for the second time succefully setup my brand new Everspring Flood sensor. The first time is work perfectly just afer setup. Some time later(an hour or so) there was no logging of any activity even when I simulated a flood. Something that work perfectly before.

I decide to delete the items and the thing and exclude it from my AEOTEC Zwave Gen 5 stick. After including it again and trough the process of setting up thing and item, in openhab, all worked perfectly again…but an hour or so later…again no communication anymore. The flood sensor works, it has an internal beep when it detects flood but the logging in openhab shows nothing.

It seems as if the sensor wakes up when flood is detected but doesn’t succeed in communicating the event to openhab…all this while the thing is “online”.

Waking up the sensor does initiate the wanted loggings but even after that simulating a flood does not activate the openhab logging.

Where should I look for the solution?


Too much distance between sensor and controller?

Also make sure the association is set to the controller. The 2.4 version of the binding had some issues with that.

1 Like

It can’t be the distance because sensor and reciever are 1m away from each other.(I’m still trying to set things up) Moreover, when the sensor was just installed, I tested the distance and everything worked fine even with a couple of walls in between. Anyway, manually waking up the sensor is reported in the log!

Whatt exactly does that mean? Where do I check if that is ok?

HABmin (or PaperUI) associations group:

Your best bet is to check your devices association group or to even upgrade to the latest 2.5 snapshot zwave binding.

For the ST812 group 1 needs to be set to the controller:

I dont use Z-Wave but it sounds like the controller or the sensor run into an timeout or something else like that.

I would recommend to make a new working setup like before and enable the Z-Wave logging.

If it is working copy some log information in working state (to compare) .

If it dont work anymore you should get some errors or other log information.

Hopfully the logging show some more information about the problem.

Enable logging:

log:set DEBUG org.openhab.binding.zwave

You can find the logfile at in your standard oh logging or in:


Take a look at the end of die Z-Wave binding documentation:

Z-Wave binding documentation


That seems to have done the job. I’m going to mark this as solved…although I wonder why the binding “lost” this association and will it loose it again?
oh well we will see!

1 Like

… not any more in 2.5 snapshot.

Wel It does! Are doesn’t it? I’m lost!

I decided to go to 2.5 snapshot this morning.
I’m 100% sure that the association to the controller was there after I upgraded. The floodsensor worked as expected. Now a couple of hours later the association in Habmin or paperUI is emty again but…a flood alarm is actually still logged by openhab.

So I guess the association to the controller is still there(otherwise a floodalarm would not have been reported in the log) but for some reason Habmin or PaperUI don’t report it anymore.

Makes you think whether or not this was the cause of the error in the first place.


There is a UI bug in Habmin that causes associations to not display properly, but you can see them in Paper UI. Configure with Habmin… view in Paper UI.

Sorry, association is not reported in PaperUI :

and not in Habmin…

device is still working as expected!!

I hadn’t noticed this… Paper UI has a display issue for association groups that only allow one device in the group. If it takes multiple, they display correctly. I’ve opened an issue for this, and included a link to the open Habmin association display issue.

1 Like