[SOLVED] Fail to include z-wave device with security - FGR-223

Hi folks,

today i started my second trail to include the Fibaro Roller Shutter 3 in my z-wave network. But I decided, that blinds as well as locks should use security. In principle openHAB 2.5 supports z-wave security inclusion and the product description states:

Supports Z-Wave network Security Modes: S0 with AES-128
encryption and S2 Authenticated with PRNG-based encryption

I searched the forum for some advice to start secure inclusion for z-wave, but haven’t found anything special. Setting the z-wave binding in inclusion mode, pressing the S1 switch 3 times rapidly and the thing shows up in the inbox. After adding it, it was detected as Roller Shutter FGR223. I checked for the Thing properties and figured out, it was not using security.

I remembered, that I saw a setting for the z-wave controller to choose device type to be included with security. I excluded the thing, set the “Secure Inclusion Mode” from “Entry Control Devices” to “All Devices”:
Z-WaveSecure

and started inclusion again. But without better success for the security mode, again including worked like a charm, but still no security.

2020-02-16 17:24:38.783 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:Razberry2:node17' has been updated.
2020-02-16 17:24:41.187 [me.event.InboxRemovedEvent] - Discovery Result with UID 'zwave:device:Razberry2:node47' has been removed.
2020-02-16 17:24:41.239 [hingStatusInfoChangedEvent] - 'zwave:device:Razberry2:node47' changed from UNINITIALIZED to INITIALIZING
2020-02-16 17:24:41.339 [hingStatusInfoChangedEvent] - 'zwave:device:Razberry2:node47' changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controller is offline
2020-02-16 17:24:41.355 [hingStatusInfoChangedEvent] - 'zwave:device:Razberry2:node47' changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to UNINITIALIZED
2020-02-16 17:24:41.393 [hingStatusInfoChangedEvent] - 'zwave:device:Razberry2:node47' changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)
2020-02-16 17:24:41.511 [hingStatusInfoChangedEvent] - 'zwave:device:Razberry2:node47' changed from UNINITIALIZED (HANDLER_MISSING_ERROR) to INITIALIZING
2020-02-16 17:24:41.532 [hingStatusInfoChangedEvent] - 'zwave:device:Razberry2:node47' changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controller is offline
2020-02-16 17:24:41.539 [hingStatusInfoChangedEvent] - 'zwave:device:Razberry2:node47' changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to ONLINE
2020-02-16 17:24:41.564 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:Razberry2:node47' has been updated.
2020-02-16 17:24:41.590 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:Razberry2:node47' has been updated.
2020-02-16 17:24:41.614 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:Razberry2:node47' has been updated.
2020-02-16 17:24:41.761 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:Razberry2:node47' has been updated.
2020-02-16 17:24:41.764 [vent.ConfigStatusInfoEvent] - ConfigStatusInfo [configStatusMessages=[]]
2020-02-16 17:24:41.768 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:Razberry2:node47' has been updated.

Is this related to my Razberry2 or do I have to set elsewhere a flag to use security? I don’t need or want to switch the existing z-wave devices (switches, dimmer, door/windows sensors and heater thermostats) to secure mode, but I would like to prevent the blinds from tampering with.

If someone was able to include the FGR-223 securely, I would be very happy to get a short how-to.

Thanks in advance
Jan

Platform information:

  • Hardware: Raspberry Pi 3 Model B Plus Rev 1.3
    • z-wave controller Razberry2
  • OS: Raspbian GNU/Linux 9 (stretch) / Linux 4.19.66-v7+
    • Java Runtime Environment: OpenJDK Runtime Environment (Zulu Embedded 8.25.0.76-linux-aarch32hf) (build 1.8.0_152-b76)
    • openHAB version: 2.5.1-2

Hi Jan,
I have the same setup and also FGR but included without security.
As far as I know if including with security does not work you have to factory reset the device before including again.
Simple delete and re-add will not work.

Some devices need to be very close to the controller at the time of secure inclusion. I do not know if this is the case for your device.

Also, just to be sure, you’re including through OH and not directly through the controller?

Sorry for the late response, I was quite busy the last weeks with no time for my Home Automation. Thanks for the hint with the factory reset, I read that, but haven’t remembered when trying to get the device included.

I’ve no my very first device running in secure mode.

Best regards Jan