[SOLVED] Failed to start resize2fs_once.services during installation

During installation of Openhabian 1.3 I’ve got following message (installation from SD image)

Is it important bug?

Michal Szymanski

Sorry to say, but it is HORRIBLE to read screenshots (almost as horrible as reading instructions as video).
Please post any messages as text and put them in </> so it is easier to read.

This is text marked with </>

Yes I know that photo is not the best way to publish error but it was happend during installation and I did not know where to find this bugs in logs :slight_smile:
Do you know where can I find linux log that is displayed during system start.

P.S Good thing is that this bug is easy to reproduce - it happend during normaln installation using SD image.

http://www.thegeekstuff.com/2011/08/linux-var-log-files

Then you have several options:

bad sd card
bad power supply
corrupted image download
bad server hardware

I will try to reinstall once again - maybe there is problem with SD card. BTW this message appear only during
installation.

I have 5A power supply but it also provide power to switches. By the way is there power stabilizer on input in RPi ?
Is it sage to use the same power supply for providing power to board with switches and Rpi or should I use separate power supply ?

Michal

The RPi is known to be sensitive to power input, I would use a separate pwr supply.

I tried and on my both Rpi2 problem exists, I’ve also tried with different SD card and power supplies. Now I’m 99% percent sure that is not related with hardware. On Rpi3 this error does not appear.

After reboot there is no such error in a log.

What is task of resize2fs_once.servie.
After next boot I’ve got:

  • [15:13:59] openhabian@openHABianPi:~$ systemctl status resize2fs_once.service
  • ● resize2fs_once.service
  • Loaded: not-found (Reason: No such file or directory)
  • Active: inactive (dead)

after I starte raspi-config and I extend partion and now I’ve got:

[15:18:24] openhabian@openHABianPi:~$ systemctl status resize2fs_once.service
● resize2fs_once.service - LSB: Resize the root filesystem to fill partition
Loaded: loaded (/etc/init.d/resize2fs_once)
Active: active (exited) since Sat 2017-07-22 15:16:40 CEST; 1min 48s ago
Process: 392 ExecStart=/etc/init.d/resize2fs_once start (code=exited, status=0/SUCCESS)

Warning: Unit file changed on disk, ‘systemctl daemon-reload’ recommended.

Should I start something?

I think I’ve found bug root cause. When I remove all partition from card and create SD card from openhabian image there is no error.

Hi, can you explain what you mean by remove all partition from card and create SD card openhabian? I am facing the same problem and can’t fix it.

Hi,
I used DISKPART command from Windows command line.

more info at:

Michal Szymanski

I tried doing that multiple times, but it still gives me that error. Do you have any other suggestions? I am using a rpi3

Find several options to format and partition your sd card here: