[SOLVED] Fibaro dimmer 2 not working what am I doing wrong

Hello community,

I am getting crazy with my z wave component.

I try to connect a Fibaro dimmer 2 with my Raspberry but it doesn´t work.

That is how I tried it:

I connected the dimmer to the wall switch, tripple klicked the b-button and waited for things popping up in the Inbox .

After the initialisation I have got 3 things in my system but none was recognized as fibaro dimmer 2. As you can see below

And the other unusual point is if I disconnect the dimmer 2 from the mains supply the z-wave node 3 is still online but the dimmer 2 is the only device in my setup until now.

can anybody help me with my problem?

Cheers Philipp

Nothing will show up in the Inbox until you press the circled buttons as indicated. (Topmost right first.)
This has to be done while the Z-Wave item is in inclusion mode.

In fact, you might need to do that first, then triple press the B button: (before OH inclusion scan terminates)

Inclusion Information

  1. Place the Dimmer 2 within the direct range of your Z-Wave controller.
  2. Identify switch no. 1 (turns the light on) or the B-button (located on the device’s housing).
  3. Set the main controller in (security/non-security) add mode (see the controller’s manual).
  4. Quickly, three times press switch no. 1 or the B-button.
  5. Wait for the adding process to end.
  6. Successful adding will be confirmed by the Z-Wave controller’s message.
1 Like

thank you for your response.

it is so frustrating it is still not working and I have no clue what am I doing wrong.

this is how i did it:


  • openhab2 ->inbox-> tripple klick b button -> scan-> zwave

Attempt 2

  • openhab2 ->inbox–> scan-> zwave -> tripple klick b button

now I have a lot of things in my system but nothing showed up as fibaro dimmer 2

and I wonder what device they are

cheers Philipp

Sorry to hear you are still struggling.

One question: how far is it from your Dimmer2 to the Z-Wave stick and are there any walls or floors between them?
Also, are you attempting a secure inclusion?

thank you for your help

the dimmer is laying next to the raspberry and I tried also with secure and non secure inclusion but it didnt work.

today I bought a FGBS001 Universal Binary Sensor from Fibaro this module is working fine.

it could be possible that the dimmer 2 is damaged I will order a new one and try a new shot.

will there be any problem if i don´t connect a load to the dimmer? beacause I connected only the wire L/N for the first test.

cheers Philipp

L+N should be enough, but I’m not sure how that will affect the auto calibration of the load.
In cases like this it’s a good idea to try a factory reset of the device.

Do you have a Z stick like Aeotec z-stick gen5 or any other connected to your raspberry pi?