[SOLVED] Fibaro KEYFOB on openhab 1.8.3 not available

I am using openhab 1.8.3 since a year and it works really great for me.
Last week I bought a Fibaro KEYFOB (FIBEFGKF-601) and tried to activate it via habmin.
The registration won’t work for me (I tried it with org.openhab.binding.zwave-1.11.0-SNAPSHOT.jar)
After searching the web I didin’t find a way to use the KEYFOB in openhab 1.8.3 version.

The only thing I found was that it will work in openhab 2.0.
Is there really no way to use it in openhab 1.8.3 ?

The database is not required to use devices in OH1, so you can use it without any change. The only time the database is needed is if you need to change the devices configuration parameters.

It can be added to OH1 if you can create an update - the database files themselves are available on the database website so just need exporting and incorporating into the 1.9 binding.

Thank you for your quick reply.
I downloaded the configuration XML for the device from z-wavealliance.org (see attachment).
Hope I understand your feedback right. Next step will be to incorporate the xml-file into the 1.9 binding .
But I don’t know how to incorporate the file ?
Will you incorporate it in the build so I can download it from the Jenkins Buildserver ?
Or can you explain it to me how to do it ?

Fibaro-Keyfob-FIBEFGKF-601.xml (51.4 KB)

Sorry - wrong database. The openhab database is here -:

and specifically the OH1 file for this is here -:

Ok, I will look to add it in the coming days.

I decided to do it now before I forget :wink: .

Thank you very much for your support.
I will download the zwave bundle from https://openhab.ci.cloudbees.com/ tomorrow.
At the moment there is no new build.
On the next weekend I am going to include it in my configuration.

Today I downloaded the zwave addon from cloudbees and installed it on my openhab 1.8.2 instance.
Afterwards I tried to include the Fibaro Keyfob, but it doesn’t work for me.
You can see the inclussion process on the screenshots below.
At the beginning I got the error message “Error serializing from file: file does not exist”.
I checked the wirte permissions but they are OK.

Any ideas to solve my problem ?

This is fine if the device is new - don’t worry about it.

It’s always better to post text logs - it’s impossible to process an image file.

I don’t see anything wrong - have you woken the device up so that it continues the initialisation?

You are absolutly right.
I had to wake up the device and everything went fine :slight_smile:

Now I have the problem to include the right zwave command in my openhab items definition.

I tried
{ zwave="46:command=sensor_multilevel"}
but it did not work for me

I receive the commands if I press a button in the following way:

> [ApplicationCommandMessageClass:41   ] - NODE 46: Application Command Request (ALIVE:DONE)
> [ApplicationCommandMessageClass:146  ] - NODE 46: Incoming command class CENTRAL_SCENE (0x5b)
> [.ZWaveCentralSceneCommandClass:77   ] - NODE 46: Received central scene command (v1)
> [.ZWaveCentralSceneCommandClass:84   ] - NODE 46: Received scene 1 ; key 128
> [b.z.i.protocol.ZWaveController:668  ] - NODE 46: Notifying event listeners: ZWaveCommandClassValueEvent
> [DEBUG] [.z.internal.ZWaveActiveBinding:472  ] - NODE 46: Got a value event from Z-Wave network, endpoint = 0, command class = CENTRAL_SCENE, value = {key=128, scene=1}

Can you tell me the right definition ?
The definitions I found in the forum are for openhab2 (with channel definition).

I doubt a keyfob would support this class.

From the log, you need to use central_scene. Unfortunately I can’t remember how this is configured in OH1 (I’ve not run it for 2 years) but maybe there’s some examples on github?

The follwoing items definition works fine for me:

/* Fibaro Keyfob */
Number          keyFobKeyScene                  "Keyfob Button"                      <button>                                    { zwave="46:command=central_scene"}
Number          keyFobKeyBattery                "Keyfob Battery [%d %%]"             <battery>                                   { zwave="46:command=BATTERY"} 

The following ruleset works for me:

rule "Keyfob button press"
	Item keyFobKeyScene changed
	logInfo("keyfob", "Keyfob button press detected")
	switch (keyFobKeyScene.state) 
		case 1.0: 
            //sendCommand(doWhatEverForSceneOne, ON)
			logInfo("keyfob", "Keyfob 1 pressed")
		case 2.0:
			logInfo("keyfob", "Keyfob 2 pressed")
		case 3.0:
			logInfo("keyfob", "Keyfob 3 pressed")
		case 4.0:
			logInfo("keyfob", "Keyfob 4 pressed")
		case 5.0:
			logInfo("keyfob", "Keyfob 5 pressed")
		case 6.0:
			logInfo("keyfob", "Keyfob 6 pressed")
			logInfo("keyfob", "Other combination: " + keyFobKeyScene.state)
1 Like

Thank you very much for your support :slight_smile:

1 Like