[SOLVED] Fibaro Temperature Controller FGT001 recognized as unknown devices

  • Platform information:
    • Hardware: Intel Atom
    • OS: Ubuntu 18.04
    • Java Runtime Environment: OpenJDK 1.8.0_222
    • openHAB version: 2.4.0-1 (package from PPA)
  • Issue of the topic: 2x Fibaro Thermostatic head recognized as unknown devices
  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

    16:32:13.175 [WARN ] [zwave.discovery.ZWaveDiscoveryService] - NODE 7: Device discovery could not resolve to a thingType! Manufacturer data not known.
    16:32:13.186 [INFO ] [smarthome.event.InboxAddedEvent ] - Discovery Result with UID ‘zwave:device:535facd2:node7’ has been added.
    16:32:13.185 [INFO ] [ig.discovery.internal.PersistentInbox] - Added new thing ‘zwave:device:535facd2:node7’ to inbox.
    16:32:13.211 [WARN ] [zwave.discovery.ZWaveDiscoveryService] - NODE 8: Device discovery could not resolve to a thingType! Manufacturer data not known.
    16:32:13.223 [INFO ] [ig.discovery.internal.PersistentInbox] - Added new thing ‘zwave:device:535facd2:node8’ to inbox.
    16:32:13.225 [INFO ] [smarthome.event.InboxAddedEvent ] - Discovery Result with UID ‘zwave:device:535facd2:node8’ has been added.

On https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/749 the devices are listed as fully supported, and as long as I was running OH on a RPi3 they were recognized perfectly. Now I’ve moved the system to an atom board and plugged the stick on it.

Even after waiting several hours, the devices remain in the inbox as unknown. Zwave connection is good - the devices are detected within seconds when doing a scan

Any good hint besides factory-reseting the stick and the termo-heads and restarting from scratch ?

Many thanks

This is a battery device, and the manufacturer data is not known so the binding cannot determine the device type. You need to wake up the device to allow this process to complete.

How to wake it up ? Putting into inclusion mode didn’t help, nor did touch the device (which makes it display the color corresponding to the configured target temperature) help

I’ve configured the ZWave stick to have a wake-up time of 60s, but that also doesn’t seem to bring changes into the inbox

As this was working using openhabian distribution : is there a different device database on this distribution which is not included in the Ubuntu PPA packages ?

I’m not sure - what does the manual say?

As I said earlier, the binding doesn’t know the device information, so the database is irrelevant. Until the binding knows the manufacturer information, it will not even look in the database - that’s what the message is saying.

Device discovery could not resolve to a thingType! Manufacturer data not known.

OK thanks. Will investigate further

Try excluding (or better, factory reset) & then including.

It shouldn’t need to be excluded - excluding and reincluding may help, but it’s highly likely to end up back exactly in the same place and you MUST wake up the device for the binding to be able to communicate with the device.

Just read the manual - it should say how to wake up the device - there will be a button to press, or some other sequence.

Actually, excluding the device didn’t work (white blinking during inclusion/exclusion mode as documented, followed by red to indicate failure) :frowning:

Manual doesn’t mention a way to wake up the device :frowning: and google also didn’t help

Went through all possible settings in the openhab interface and found the Secure Inclusion Mode setting, that was set to “Entry control devices”. Changed it to “All devices”, which reconfigured the stick (according to the logfile) and restarted it

17:44:40.232 [INFO ] [smarthome.event.ThingUpdatedEvent ] - Thing ‘zwave:serial_zstick:535facd2’ has been updated.
17:44:43.312 [INFO ] [ding.zwave.handler.ZWaveSerialHandler] - Stopped ZWave serial handler
17:44:43.355 [INFO ] [ding.zwave.handler.ZWaveSerialHandler] - Connecting to serial port ‘/dev/ttyUSB0’
17:44:43.382 [INFO ] [ding.zwave.handler.ZWaveSerialHandler] - Serial port is initialized
17:44:43.418 [INFO ] [ave.internal.protocol.ZWaveController] - Starting ZWave controller
17:44:43.425 [INFO ] [ave.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.
17:44:43.471 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘zwave:serial_zstick:535facd2’ changed from ONLINE to OFFLINE (BRIDGE_OFFLINE): Controller is offline
17:44:47.573 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘zwave:serial_zstick:535facd2’ changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to ONLINE

Afterwards, the two devices were recognized as Fibaro FGT001’s - as expected

No idea if the setting is the key or if the stick just needed a reconfig and reset to come into proper operation mode, but now it seems to work

Sorry for the noise !

1 Like

I just had a look at the manual - this is a FLiRS device, so it automatically wakes up once per second. Without logs I’m not sure why it didn’t work initially, but you could be right that it just needed a reset.

Some of my cheap Chinese sensors needed a reset from new before successfully included.

Maybe, but once a device is included, the next step is to wake it up - it should not be necessary to exclude it and re-include it. It’s possible that this may work, but only because the inclusion keeps the device awake for a few seconds, but if it sleeps, then you’re still in the same boat.