[SOLVED] Fonts error, not able to see any chart - 2.5.0~S1731-1 (Build #1731)

Hi folks,

I’ve upgraded from #1657 to #1712 and I’ve the same problem as:

The problem here I don’t have a docker, just a simple openhabian installation in a VM (VMware). With the latest OH (2.5.0~S1731-1 (Build #1731)) same issue.

I’ve tried to install fontconfig via apt-get, but it didn’t solve the issue.

Any clue?

here the log: https://justpaste.it/4wa9y

Any suggestion will be appreciated


Like any snapshot tester, please file an issue on GitHub. As you know, snapshot builds are not expected to be fully functional. They are designed to find issues such as this but it needs to be reported where it can be resolved.

What is your persistence? Is it running? Is is set in PaperUI --> Configuration --> System --> Persistence --> Default Service? If there is your correct entry? You should try: remove it, save empty, fill it in again, save again.

it was working perfectly on #1657, so it’s not a persistence issue.

Github issue opened: https://github.com/openhab/openhabian/issues/748


I’ve updated from 1486 to 1731. I had a similar problem with rrd4j. I did what I mentioned one post before, and then it was running again. But maybe it’s different to your problem.

the problem is the default for me is not rrd4j, but mapdb. rrd4j is used for some charts (the charts that have problems now)

maybe I can try to remove the configuration of rrd4j, restart, then stop and re-add.

mmm …

I would try to backup your rrd4j database and rrd4j configuration. Then uninstall rrd4j persistence. Reinstall it again. Check your config again.

nothing …

after quick investigation, it seems there is an issue with openJDK … maybe we need to start it in headless mode


but I don’t remember where is the right config in openhabian :frowning:


wrong … it’s already configured:

ps -ef | grep openhab
openhab    2452      1  0 Oct22 ?        00:01:05 node /usr/bin/frontail --ui-highlight --ui-highlight-preset /usr/lib/node_modules/frontail/preset/openhab.json -t openhab -l 2000 -n 200 /var/log/openhab2/openhab.log /var/log/openhab2/events.log
openhab    2463   2452  0 Oct22 ?        00:00:18 tail -n 200 -F /var/log/openhab2/openhab.log /var/log/openhab2/events.log
ariela    55292  54906  0 10:35 pts/1    00:00:00 tail -f /var/log/openhab2/openhab.log
openhab   62204      1 24 11:03 ?        00:03:27 /usr/bin/java -Dopenhab.home=/usr/share/openhab2 -Dopenhab.conf=/etc/openhab2 -Dopenhab.runtime=/usr/share/openhab2/runtime -Dopenhab.userdata=/var/lib/openhab2 -Dopenhab.logdir=/var/log/openhab2 -Dfelix.cm.dir=/var/lib/openhab2/config -Djava.library.path=/var/lib/openhab2/tmp/lib -Djetty.host= -Djetty.http.compliance=RFC2616 -Dorg.ops4j.pax.web.listening.addresses= -Dorg.osgi.service.http.port=8080 -Dorg.osgi.service.http.port.secure=8443 -Djava.awt.headless=true -XX:+UseG1GC -Dgnu.io.rxtx.SerialPorts=/dev/ttyACM0 -Djava.endorsed.dirs=/opt/jdk/zulu8.42.0.21-ca-jdk8.0.232-linux_i686/jre/lib/endorsed:/opt/jdk/zulu8.42.0.21-ca-jdk8.0.232-linux_i686/lib/endorsed:/usr/share/openhab2/runtime/lib/endorsed -Djava.ext.dirs=/opt/jdk/zulu8.42.0.21-ca-jdk8.0.232-linux_i686/jre/lib/ext:/opt/jdk/zulu8.42.0.21-ca-jdk8.0.232-linux_i686/lib/ext:/usr/share/openhab2/runtime/lib/ext -Dkaraf.instances=/var/lib/openhab2/tmp/instances -Dkaraf.home=/usr/share/openhab2/runtime -Dkaraf.base=/var/lib/openhab2 -Dkaraf.data=/var/lib/openhab2 -Dkaraf.etc=/var/lib/openhab2/etc -Dkaraf.log=/var/log/openhab2 -Dkaraf.restart.jvm.supported=true -Djava.io.tmpdir=/var/lib/openhab2/tmp -Djava.util.logging.config.file=/var/lib/openhab2/etc/java.util.logging.properties -Dkaraf.startLocalConsole=false -Dkaraf.startRemoteShell=true -classpath /usr/share/openhab2/runtime/lib/boot/org.apache.karaf.diagnostic.boot-4.2.6.jar:/usr/share/openhab2/runtime/lib/boot/org.apache.karaf.jaas.boot-4.2.6.jar:/usr/share/openhab2/runtime/lib/boot/org.apache.karaf.main-4.2.6.jar:/usr/share/openhab2/runtime/lib/boot/org.apache.karaf.specs.activator-4.2.6.jar:/usr/share/openhab2/runtime/lib/boot/org.osgi.core-6.0.0.jar org.apache.karaf.main.Main
ariela    63938  57691  0 11:17 pts/2    00:00:00 grep --color=auto openhab


Sorry I’m not using Openhabian and I’m not a Linux specialist, but please check this three links:



the solution is in:

sudo apt-get install fontconfig:i386

did the trick for me (even on amd64 vm).



I was not so far away with: sudo apt-get install fontconfig (in links above…) :smiley:

yep right :slight_smile: the problem is the “generic” command will install the version correct for your platform (in my case amd64) … but openhab works with 32 bit version, so you need the i386 :slight_smile:

ahahaha … crazy :slight_smile:

1 Like