[SOLVED] gpsTracker Distance Channel Error 500


I have a working GPSTracker setup on OpenHABian, using the OwnTracks app. The addon was installed via PaperUI/Addons, and all items/things were created within PaperUI (not via .items or .things files).

I am now trying to add the Distance channel for GPSTracker, however no matter what i do it gives me an error 500 internal server error.

The configuration i am putting in to the channel set up is:

Channel Type:Distance (this is a dropdown menu, only option showing)
Channel ID: gpstracker:tracker:XX:regionDistance
Label: Distance
Region Radius: 5500 (meters?)
Region Centre: LAT, -LON
Accuracy Threshold: 0 (tried with 50 as well but makes no difference)

I cannot find any reference to this error in the openhab.log to indicate what is causing the issue.

Please could someone help me to find out what is causing the error, or advise if there are any special requirements to use this channel?

Thanks in advance.

Region Name is required

Metres or Yards depends on your UoM set-up, if you have chosen Metric it will be metres
Accuracy threshold 10 work well for me

I had been putting Home in that field (sorry missed it when typing the original post) - i put the same region name as the region set in OwnTracks.

Good to know about the UoM, i ahve set to imperial so will need to work out the distance in yards.

This is incorrect.
Just enter Home

1 Like

That’s worked a treat, thanks so much :smile:

I’m still getting Error500. Could you provide your complete configuration as exemple. I don’t understand what I’m missing. Thanks !