Solved! Grafana don't plot some data

  • Platform information:
    • Hardware: CPUArchitecture/RAM/storage RPI3
    • OS: what OS is used and which version Openhabian 1.4
    • openHAB version:2.2

This is my newbie question:
I’ve installed a raspbianpi 1.4 into the RPi 3 without problem. Then I’ve setup InfluxDB (1.4.2) and Grafana (4.6.3). OH2.2 pumps the sensor data into the influxdb and i can see the series in the data base. But plotting this data with grafana has not been possible since a certain moment, without changing the configuration.

For example: Accu_temp_top sensor data can be displayed without problems until 2/21 19:12, as shown in the following figure, but no value is displayed from that moment. But if the database is consulted (with the same command that grafana uses), all the data appears.

I don’t know where else I can look. Any help will be welcome!


Are you sure your item gets updates with new values?

Does openhab.log show any errors?

You might want to post your items and rules file. Maybe we see something you did not. :slight_smile:

Thanks for the answer @christoph_wempe.

I believe that OH2.2 is working correctly: there are no errors in openhab.log nor in syslog. OH2.2 reads the data from the sensors via mqtt and show them in the test sitemap and then puts them into the influxdb.
The problem is that grafana does not get certain data from the database … and in influxdb console I can see that data.

Solved! I’m sorry, it was my mistake. When configuring the grafana database I put an old server IP.