[SOLVED] Home Energy Meter HEM G3 AEON Labs GEN5 ZW095 do not report automatically

This is old and I hope you can remember what are the exact steps using the Zensys tool to set the correct associations?

Very strange.
After adding the node with Zensys and loading up PaperUI (thing added from Inbox)
I see the following in PaperUI (Controller appears 2 times in Lifeline):


Sorry - I’m still waiting to hear back from Aeon on this.

Without knowing exactly what you’ve done, this is probably as you have now duplicated the associations. This is really a messy area of ZWave - it’s gone through a lot of change in the past couple of years and there are something like 8 or 9 command classes linked directly to associations. On top of that there are a lot of non-compliant implementations which is caused by the ever evolving standards.

Here is the sequence of events:

  1. Removed and reset device from network.
  2. plugged the UZB to a PC running Zensys tool.
  3. Set controller to SUC in Zensys.
  4. Initiated a scan in Zensys for new devices.
  5. Pushed device button to be added to the network.
  6. The device appeared as a new node in Zensys (it’s name appeared as a generic Z+ switch, meter node). I did not initiate any other configurations or settings through Zensys as I did not know where (see post above).
  7. Removed UZB and plugged into the RPi, loaded openHAB. The new thing appeared in PaperUI Inbox, just clicked “add”, with a node name I chose instead of the default.

The new node appeared in the things list with the Lifeline set as noted above (Controller, Controller).
I did not do any other modifications and noticed that the reporting is working as it should, which did not work before.

Yes, it is as I stated earlier. You will have now duplicated the association.

Could you please explain in technical wording what do you mean, what are the implications of it?
I would also appreciate it if you could add some reference reading material to understand what it means?

Thank you.

Found some interesting doc about the MC association: https://www.silabs.com/documents/login/application-notes/APL12955-Z-Wave-Multi-Channel-Basics.pdf

I can only really refer you to the ZWave protocol standards unfortunately, but there’s a lot in there.

Basically there are two association classes, and for each class there are multiple versions that do completely different things. Due to the evolution of the classes (especially the MC Association class) there are a number of implementations that don’t conform to the standards as the standards were evolving so quickly. This makes it hard for the binding to know what to do.

This is what I’m trying to get clarified by Aeon.

Did you recieved news from them? :blush:

Just bought the same device (1 clamp only), and having the same issues.

  1. With a rule and refresh, data is coming in.
  2. But nothing leads to having the data coming in from the meter. Tried hunderds (?) of thing in the paperUI settings, but nothing seems to help.

No - I pinged them a few times after I go the response that they would look at it, but I never got the answer. I’ll try again - normally they are really good, but recently (maybe due to the world situation) it’s been more difficult to get responses.

Hey everybody
I have a problem with this device after I changed the controller and reincluded the device. Before i changed teh controller he send a status change after a change of 5% . Then after the inclusion it did send every half hour with the same parameters. Now after i deleted it and reincluded it again. It doesn’t sent new value’s anymore. It is online and when i reinitiliase the device it does everything it has to do. Here is the log debug node 13 zw095.txt (137.8 KB) . Then if i want to chance a parameter i get this debug node 13 para.txt (722 Bytes) . The XML file is only 5kb network_eeeed13d__node_13.xml (5.1 KB). I have already deleted the device from habmin and the xml file and then search for a new zwave device, but didn’t work.
I run an RPI 4 2GB, openhabian, razberry controller. If i put my controller on a zway server everything works well so i don’t think it’s the device.

Did you solved this,
I’m using a rule every 10 seconds that refreshes the meter. This ‘forces’ him to send over the data…

sendCommand(ZW095a_reset, “REFRESH”)

Yes it is solved… I removed it form the network with z wave.me and included it again I did that by marking the device as failed and then gave it a reset and then click replace by new device… so nothing was changed in my network but now al works great! But Thx for the advice can be handy for something different… :slight_smile:.

After a lot of testing, reading logs and forum posts as well as contacting Aeotec support I finally got the device working correctly.

I made a howto here: Make Aeotec Home Energy Meter send automatic updates


Pretty old post but it still applies.
Recently upgraded to OH3 and some weeks later, installed the HEM. Right after the install the readings were getting update only once every 30 minutes or so - found no way to change that. Some days later, after fiddling around in OH, meter readings froze - no more updates.
Installed the Zensys tools today - made the changes in the assocation classes as per you info and - tadaaa - working like a charm now - updated every x seconds as requested.
So even after 2 years, the configuration issue is till there …
Thx for pointing to the solution.


Adding to this thread instead of starting a new one…

I’m having the same issue as many others reported, can’t get this device to update every x seconds as configured.

I had this device working fine on OH 2.5 but when I created a fresh OH 3 system I got the updating issue. Basically excluded everything and added all devices as new.
Device will report values occasionally but not according to the Report Group parameters, 101, 102, 103

I followed the advice of others and used the Zensys tool to set the Association as recommended and remove the Multi-Associations and it did bring some progress but not total success.

@chris , I’m willing to post some logs but wanted to make sure DEBUG logging of the association process is sufficient, or is there something more needed?

Hello, I think i can solve this for you -

I followed this instructions set for zensys

I then reached out to AEON for advice also - Pls see answer here

""Ticket: XXXX

It has an issue with Group association, there is one quick way to fix this, is to use your Z-Stick Gen5 manual pair method which should assign the proper group association.

  1. Unpair HEM Gen5 from your Z-Stick Gen5.
  2. Unplug your Z-Stick Gen5
  3. Tap the button on Z-Stick Gen5 - slow blue blinking LED
  4. Tap the button on HEM Gen5
  5. Plug the Z-Stick Gen5 and connect it back into OpenHAB

    This should allow the proper group association to function have the HEM Gen5 automatically report.

Alternatively, you can use Zensys tools to pair your HEM Gen5 using similar steps to the above, which should do about the same thing and then move it over to OpenHAB afterwards. “”

I had done thing the first way and it didnt work, so I went the Zensys method (alternative). I plugged the AEON Zwave stick in my Laptop - went to remove + re - add and it seems to configured fully. Now i can play around with all variables. I use 101 at 5 sec intervals with 1794 to get all Wattage and 102/112 with setting for Kwh. all seems to work perfectly now.

Hope that helps

Thanks! I’ll give this method a try.

Worked like a charm!

Including from Openhab did not work but including manually from the stick worked.

1 Like

Thanks for your update,
Just to make sure what is the channel you are using to get the data?
is it “meter_current” ?