[SOLVED] Home Energy Meter HEM G3 AEON Labs GEN5 ZW095 do not report automatically

Tags: #<Tag:0x00007fc202411ad8>

Hi,

I bought a Home Energy Meter HEM G3 AEON Labs GEN5 ZW095 and tried to configure it via HABmin.

http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/375

Unfortunately without success. The only report I get is after 10 minutes of polling.


I get the new values every 10 minutes for all things.
image

Has anyone configured the Home Energy Meter that there are always certain changes in the watts reports to openhab? by Parameter 4-10? or by 2 and 101-113?
I have already tried a lot, but unfortunately nothing worked.

openHAB 2.3.0 Build #1241

thank you for your help.

I tested something else; Unfortunately without success. :sob:
I also enabled DEBUG mode to see what NODE 35 do.

DEBUG NODE 35.xml (82.7 KB)

(please excuse the XML file, but unfortunately I could not post the LOG directly. It was too big and XML the only way to post it)

During the report I tried to reduce the report value and then increased again (Parameter 111).
BTW: I upgraded my version to latest openHAB 2.3.0 Build #1272

@chris: Do you have any idea whats wrong? Should I exclude and include the device again?

In HABmin I see followings:

Z-Wave Controller:

Z-Wave Network Viewer:

I also tried this both settings:
image

Now I have the device excluded and includes again.
Unfortunately without any success.
Now the device will be displayed as neighbor of the controller, but will not send a report from the device to the controller.

Unfortunately, no one has responded to my question, so I have to accept this condition now probably? :cry:

Today I had a web session with an engineer from Aeotec.
The engineer used ZENSYS for Windows and we have all configured their.

The openhab Zwave binding via Habmin does not set (partly) the parameter for ZW095!
(This means that association group 1 was not set and could not be set.)

After that, I had the values I wanted in Openhab.

@chris The error may be in the XML for the device?

Another note at this point:
If you also want to have an automatic report for WATT, you must disable the parameter 3.
Otherwise, all values will be given but not the WATT values.

I have to praise the engineer, we have solved the problem in a websession over 2,5 Hours.
He also gave me a good look at the Zensys tool and how I can set and test parameters myself in the future. He also sent me some instructions and help.
Thanks Chris from Aeotec Support.

Very great job THANKS

Please provide a debug log and explain what parameter you are setting, and to what value - there could be a lot of different reasons why this doesn’t work.

@chris
After the last experiences with other Z Wave products, I took a closer look at the problem of that time.
Probably the problem was with the Assocation Groups.
This was not set correctly and could not be set on HABmin.
With the engineer this was set by the ZENSYS tool at that time.

image

There are many topics in the community on this topic. ( Assocation Groups, Lifeline etc.)

Apparently the topic Association Groups is a bit buggy in stable and snapshot Z-Wave binding.
There is probably a solution in the DEV Z-Wave Binding, which I have not tested.

The issue of associations is not a simple one - in recent years. It used to be easy - there was one class, and configuring an association was clear.

Now there are 2 classes, and at least 3 different versions of this class, and each version has very different ways of working. To make it worse, manufacturers haven’t necessarily implemented this correctly - mainly due to the confusion with the changing nature of these versions. It’s easy when you have a device, and a simple piece of software that you can choose exactly how to set each group, but the binding needs to decide which way to configure the association and there’s something like 4 or 5 different ways :frowning: . Qubino told me that their older devices don’t work properly and are non-compliant to the requirements, and I’m sure that there are a lot of other devices out there in the same boat.

It is definately true that the current master (which means stable and snapshot) has not had the fixes that the development binding has. That’s not to say that in all instances the dev binding will work 100% either - but it is a lot better.

The dev binding will automatically configure the lifeline - no matter how the database is set (of course this is only relevant for ZWave Plus devices). It then tries to make a the right choice of command to use to set other associations - this is based on the command class versions, and the number of supported endpoints (this is very important in the newer classes as there are multiple ways to send the same command).

Since there are some devices that are non-compliant, it’s going to be hard to have a system that works for every device, but we can try.

Hopefully in the near future we should have the dev branch merged into master, then we can look more at any remaining issues.

Thank you very much for your comments.
This makes some more understandable.
I have learned a lot about the topology of Zwave and understand now more through your explanations.

Yes, at first I also thought that the problem is a different reason. (false parameter etc.)

Is there any way (stable, snapshot, DEV) to redefine the Assocation Group 1, Lifeline?

My problem is / was that I can put these groups in HABMIN, but they are not saved, or they are empty after updating the site and did not sent to the Z Wave devices.

With the engineer we could set the Assocation Group with ZENSYS Tool directly on the UZB Stick.

Hi Stefan,

I’m facing the same problem with the HEM (ZW095) only updating on the 10 min poll interval. I have set multiple parameters in 101-113, but it’s not giving me what I want, which is a data push at 60-second intervals. I have disabled the selective reporting and I have also set the association groups for group1 to “controller”.
I’m running openHAB 2.4.0 Build #1364 (snapshot).

Could you tell me what parameters need to be adjusted on the HEM with ZENSYS, or perhaps you know how to do it in PaperUI or HABmin?

Thanks for any pointers.

Could you please post some screenshots of the configuration parameters (maybe just the one that are enabled for 101-113)?

Hi Scott,

This is my current config, but I had different values in 101 taken from the examples provided in the z-wave binding database.

Thanks for looking at this.

OK, that’s a valid number for a report. Have you power cycled the HEM? There’s also a note in the G1 db entry that may be helpful. Power cycle with the button held to have the device reread it’s config. Don’t hold the button too long or it will reset. I’ve also just pushed the button while it is running and this seemed to help get the configs.

Also, I’ve had to resend the report value at times to get them to take. Change it, save it, then change it back to what you wanted and save.

1 Like

I will send you a document from the aeontec guy via PM

Scott,

Thanks for pointing that note out, but even after a reboot while holding the button, the reports are still only sent every 10 mins.
I have watched the debug log when setting and un-setting some parameters and I can see them being accepted by the device, but the net effect remains the same.

Here is parameter 111 (6F) receiving a setting of 60 (3C):

09:17:18.064 [DEBUG] [ding.zwave.handler.ZWaveSerialHandler] - NODE 11: Sending REQUEST Message = 01 0F 00 13 0B 08 70 04 6F 04 00 00 00 3C 25 F6 10 

The device responds back to a CONFIGURATION_GET command with the following command, but I’m not sure of the structure of the returned frame…

09:17:18.118 [DEBUG] [ding.zwave.handler.ZWaveSerialHandler] - NODE 11: Sending REQUEST Message = 01 0A 00 13 0B 03 70 05 6F 25 F7 26 

I then send the parameter 111 a new 30 (1E) soon after…

09:17:22.029 [DEBUG] [ding.zwave.handler.ZWaveSerialHandler] - NODE 11: Sending REQUEST Message = 01 0F 00 13 0B 08 70 04 6F 04 00 00 00 1E 25 F8 3C 

Stefan sent me some info separately which I’ll give a go tonight, if I can.

Here is a post with a log that shows what you should see reported after the CONFIGURATION_GET.

Did you follow all the steps for updating to this version of the binding? Are your Things managed or unmanaged (.thing files)?

Yes sir, 1 to 10, including 1. :slight_smile:

All of my things are managed (by habmin), I have no .thing files.

Do your logs show a response to the CONFIGURATION_GET? If not, I’d double check the one that locks the settings (I pretty sure I saw that in there when I looked yesterday). Also, try pressing the button and immediately sending the config change. If all else fails, I’d exclude the device, reset it, then include it again.

EDIT: The below is incorrect - it was the way that I had configured grafana to display the data which caused it to fill null values with previous data. Sorry!

Hi all,
So firstly, the reporting is now working but it has confused the hell out of me.

Here’s what I don’t understand:
I’m watching the openhab debug log via karaf (openhab-cli console -> log:tail (running under “error” mode)) and from here I can see various item values coming into openhab and I can what devices are checking in and how often. An example is below showing some HEM values with some snmp traffic, etc.

2018-09-19 22:29:06.551 [vent.ItemStateChangedEvent] - zwave_device_c7937d7e_node11_meter_kwh changed from 5.402 to 5.42
2018-09-19 22:29:06.599 [vent.ItemStateChangedEvent] - zwave_device_c7937d7e_node11_meter_voltage changed from 232.099 to 230.871
2018-09-19 22:29:06.644 [vent.ItemStateChangedEvent] - zwave_device_c7937d7e_node11_meter_current1 changed from 0.775 to 0.79
2018-09-19 22:29:06.645 [vent.ItemStateChangedEvent] - HEM_current1 changed from 0.775 to 0.79
2018-09-19 22:29:06.692 [vent.ItemStateChangedEvent] - zwave_device_c7937d7e_node11_meter_watts1 changed from 85.576 to 85.792
2018-09-19 22:29:06.693 [vent.ItemStateChangedEvent] - HEM_watts1 changed from 85.576 to 85.792
2018-09-19 22:29:06.735 [vent.ItemStateChangedEvent] - zwave_device_c7937d7e_node11_meter_kwh1 changed from 5.402 to 5.42
2018-09-19 22:29:06.736 [vent.ItemStateChangedEvent] - HEM_kwh1 changed from 5.402 to 5.42
2018-09-19 22:29:06.780 [vent.ItemStateChangedEvent] - zwave_device_c7937d7e_node11_meter_voltage1 changed from 232.099 to 230.871
2018-09-19 22:29:06.781 [vent.ItemStateChangedEvent] - HEM_voltage1 changed from 232.099 to 230.871
2018-09-19 22:29:30.529 [vent.ItemStateChangedEvent] - snmp_pfsense_lan_ifInOctets changed from 2218749951 to 2219227125
2018-09-19 22:29:30.535 [vent.ItemStateChangedEvent] - snmp_pfsense_wan_ifInOctets changed from 3395994461 to 3396028384
2018-09-19 22:29:30.540 [vent.ItemStateChangedEvent] - snmp_pfsense_lan_ifOutOctets changed from 4105562541 to 4105807751
2018-09-19 22:29:30.543 [vent.ItemStateChangedEvent] - snmp_pfsense_wan_ifOutOctets changed from 3395994461 to 3396028384

As of earlier this evening, I noticed that I started to get 60-second based updates in my Grafana tables, these had been 10 min updates before this. So I was initially delighted, but then I looked back at the karaf console to see why I missed the 60-second updates from the HEM - but I don’t see any updates at 60-second intervals!

I was under the impression that all changes to all things were verbosely printed to the log, but is this not correct?
If not, other than looking at the individual tables in influxdb, where should I be seeing the incoming data at an item level?

Let me know if this isn’t clear.

You are seeing all of the item changes and updates. You’ll also find them in the events.log file.

Scott, sorry you are correct. I had setup grafana to “fill (previous)” and it made it look like it had received data points where it had not.
I continue my search for a fix to the lack of updates from the HEM.