[SOLVED] HomeKit / Siri Issues - Help Please

I have an issue using Siri with Openhab. This problem has only just presented since upgrading to OpenHab 2.4M6, but I did make a few other changes at the same time as the upgrade, so I’m not sure it is a M6 related issue.

In a nutshell - when I issue a command via Siri for item ‘A’, Siri operates item ‘A’ AND item ‘B’ (either on or off).
So when I ask Siri to “Turn off the can crusher” she turns off the can crusher AND also turns off the garage door!

I have spent some time trying to track this issue down - here is what I have done so far…

  1. UnLinked Homekit and removed the home - recreated home and Openhab link
  2. Stopped Openhab and cleared the cache directories
  3. Removed and reinstalled the Homekit Service
  4. Upgraded to 2.4M8

None of these has fixed the issue.

I now think that this is a Siri problem and NOT a Homekit problem - if I issue the command using the HomeKit App on my phone everything is fine (only the correct item switches). It is only when I give a verbal command via Siri that the problem presents.
One other clue - when I ask siri “to turn on garage light” (a device with out a problem) the text reply on my phone is “Ok the garage light is ON” .
When I ask Siri to “Turn on the can crusher” (the item with the problem) she turns on the can crusher AND (incorrectly) turns on the Garage Door and responds “The switches are on” (note the plural ‘switches’.
It is almost like Siri thinks that the “Can Crusher” is a group or some sort??

I have turned on a trace for Homekit and the log entries for the command in error are over 2500 lines long - and to be honest, they have no meaning to me.

Can somebody please offer some suggestions (I can post the log trace if that would help)

Many thanks

had same issues i think this is apple fault not OH…
but was not able to find a soultion … it got fixed by its own…

Hmmm - does that mean I should blame the wife? :slight_smile:

So, just to confirm … you made no changes and it just fixed its self?

i did a couple of paring un paring homekit from OH also did from the Ipad , finally got resolved not sure how…

are you aware of the paring steps?

look for smarthome:homekit clearPairings

and you should always blame the wife :slight_smile:

Solution - for anyone else who has this strange issue.
After doing about 4 ‘delete home’, ‘clearParings’ and uninstalling the binding with no result, I finally removed the [ “Switchable” ] tag from the item that was incorrectly switching. This immediately solved the problem. Re-adding the tag a few minutes later caused no problems.
I am sure that this is an Apple problem and not an OpenHab problem - as it ONLY happened when using voice commands to Siri. (I’m sure the wife had something to do with it too :slight_smile:)

are you sure its not the wife :thinking:

i will try the above if i have this issue thanks allot!