[SOLVED] Homematic IP Dimmer is read only

Hi Openhab Fans,

i run my OH in a docker with :latest (should be 2.4.0) and needed to replace one of my homematic dimmers (HM-LC-Dim1TPBU-FM) which broke.

In order to be more “Future proove” i decided to go for a HM-IP version of it. (HmIP-BDT)

Installation went fine, i could bind it in the CCU and it showed in the inbox of openhab, so i could install it. Was pretty happy about it. I had the hope, i could directly replace the thing chanel in the old item definition.

i linked to the first of the 3 virtual dimmers, whcih looks like:

    Dimmer  LichtCouchtisch "Sofa [%d %%]" [ "Lighting" ] { channel="homematic:HmIP-BDT:a8faecaa:0008DA498E78FB:3#LEVEL" }

    //oldDimmer  LichtCouchtisch "Sofa [%d %%]" [ "Lighting" ] { channel="homematic:HM-LC-Dim1TPBU-FM:a8faecaa:MEQ0168594:1#LEVEL" }

I copied the linkage string with the button on paper ui and pasted it, so I’m 110% sure it is correct.

Just it does not work :frowning:

when i try to set the dim level, i get in the log a:

2019-11-14 19:10:02.599 [WARN ] [ommunicator.AbstractHomematicGateway] - Datapoint is readOnly, it is not published to the gateway with id 'a8faecaa': '0008DA498E78FB:3#LEVEL'

I updated the openhab to 2.4.0 and the homematic to 2.47.20, ensured Firewall Access in the OH, have no authentification enabled. My other (ordinary none IP) switches and dimmers run fine

Any hint what i made wrong?

Best Regards

Edit: I forgot to mention: The “Reading” works flawlessly. I can change the dimmer on the deveice or in hemematic UI, openhab will see the updates.

I tried yesterday to put org.openhab.binding.homematic to loglevel trace - but this did not help either; at least it did NOT show tracing entries.

Now I’m really stuck.

The obvious next step for me would be to replace the IP dimmer back with an ordinary one :frowning:


I’m still surprised, that

log:set TRACE org.openhab.binding.homematic

brings no trace entires in the log, and

stop org.openhab.binding.homematic

(and start) claims none existence of the bundle.

In the source code on github i can see, them message “Datapoint is readOnly, it is not published to the gateway with id” comes when (tada) the datapoint is set as readonly. I see it is done somewhere in the CommonRpcParser - which ends up with the face that i have no real clue, how this thing works :slight_smile:

Any hint still apriciated

maybe the path is not org.openhab.binding but something different? use bundle:list | grep homematic to get the correct path.


224 x Active   x  80 x 0.10.0.oh240           x Eclipse SmartHome Homematic Binding

how do i get the path on that?

ah, sorry it’s feature:list | grep homematic.

I guess the correct path is org.eclipse.smarthome.bundle.homematic then.

You can check this with typing bundle:info org.eclipse. and then hit the tab for auto

Unfortunately log:set does no auto completion at all.

1 Like
openhab-binding-homematic1                  x 1.13.0           x          x Uninstalled x openhab-addons-legacy-2.4.0 x Homematic Binding (1.x)
esh-binding-homematic                       x 0.10.0.oh240     x          x Started     x openhab-addons-2.4.0        x
openhab-binding-homematic                   x 2.4.0            x x        x Started     x openhab-addons-2.4.0        x Homematic Binding

ok, auto complete shows org.eclipse.smarthome.binding.homematic

and that floods my log imediately :slight_smile:. I’ll have a look after dinner!

(Trace Removed)

Well, i did trace a HM stop / start sequece and a try to switch it. On the very end the known message “readonly…” is shown.

I can see a lor of request/response pairs, but what does it tell me?

Any Ideas?

In english, please :wink:

Upps - :flushed:

Aaaaaand the soltution is:

Instread of

  • homematic:HmIP-BDT:a8faecaa:0008DA498E78FB:3#LEVEL

i should have used

  • homematic:HmIP-BDT:a8faecaa:0008DA498E78FB:4#LEVEL

Or in readable words, i had used the Dimmer Transmitter; I should have used the Dimmer Virtual Receiver Channel.

So, the problem was sitting in front of the Keyboard.

No i have to find and fix a different issue: if i set the light to 100% is OH, it is still rather dim :-/. Probably i have to touch the channel logic…

Have you tried to set the light to 99%?

I’m having the problem that the range 0% - 99% in openHAB is mapped to 0% - 100% in Homematic. Thus, setting the light in 99% will result in full brightness of the dimmer (i.e. 100%) whereas setting the light to 100% in openHAB will translates to 101% and results in a rather dim light level.

True, in can 100% confirm that bug.

i did not see a bug report yet, so i created https://github.com/openhab/openhab-addons/issues/6996