[SOLVED] Homemeatic CCU3 no Switch events only RSSI

Hi all!
I am using CCU3 and openhab 2.3 and I have the following problem:
When using Homematic IP Items everything gets installed correctly, all items found all channels detected.

For some reason I only get a very reduced set of events after pressing a button:

17:29:50.166 [INFO ] [smarthome.event.ItemStateChangedEvent] - HMAlarmtaster_0RSSIDEVICE changed from -78 to -71
17:29:50.166 [INFO ] [smarthome.event.ItemStateChangedEvent] - HMAlarmtaster_0RSSI changed from -78 to -71
So I don’t get any relevant event to be used within a rule.

Please can anybody help?



I remember a problem with HMIP devices some weeks ago. You can try the latest Milestone Build of 2.4? If not please enable the trace for the Homematic binding, and attach post the output here.

Many thanks for the quick response!!

I found the solution myself in the Openhab Docs, good job stating it there:

If you want PRESS events from HmIP you need to create a program in the CCU where you just mention the channels of the device in the IF-statement

After having this implemented openhab suddenly fires the events correctly.

Many Thanks!!!


I have also tried the latest buid 1.4 from yesterday 3.11.18: Beware: CCU3 and openhab are not able to create a stable connection at all! Also not after creating a larger connection timeout. If any device triggers a channel the connection breaks down.