[SOLVED] How can i install the old mqtt action?

using oh 2.4 on pi 4

i know its not supported anymore, but for now i dont have time to sort the new one, there is a way to install tthe ols mqtt action?

thanks

Go to the paper user interface. Click on the Add-ons menu item on the left. Then click on the ‘ACTIONS’ heading on the top of the main window. Give it a second to load them all and then you should see:
MQTT Action
action-mqtt - 1.12.0
Click install

I already checked. The is no matt action in the add-ons

You need to activate legacy bindings in the paperUI settings page.
BUT the action is NOT compatible with the new v2 MQTT binding.

Where did you get a pi 4???

If you still want to use the MQTT v1 binding AND action you will need to uninstall the MQTTv2 binding,
enable legacy binding, install MQTTv1 and action.

If you want to use the MQTTv2 binding there is a new action available: https://www.openhab.org/addons/bindings/mqtt.generic/#rule-actions

1 Like

LOL im using pi3, it was typo mistake

i did not install MQTT v2, do i need o restart after enable legacy binding? because i still dont see it
thanks

I don’t know to be honest.
Have you tried?

When you click to turn on legacy bindings don’t forget to also click save located in bottom right corner. Otherwise you won’t have the legacy bindings.:wink:

1 Like

Just a note, the MQTT 1 Actions requires the MQTT 1 Binding. It will not work on its own and it will not work with the 2.4 MQTT binding.

Thanks after reboot it show

yes i know

i’m not using the binding, only the Mosquitto

If you are using the MQTT Action then you must also have the MQTT binding installed. The MQTT Action cannot work on it’s own.

But it’s working and both mqtt not installed

If you are using the separately install MQTT Action then the ONLY way it can work is if the MQTT 1 Binding is also installed. So either you are using the MQTT 2 Action (which gets installed with the MQTT 2 binding) or you are mistaken and you do have the MQTT 1 Binding installed too.