[SOLVED] How to install MQTT on openHAB2

Hi, I have installed the beta 5 release of OH2 on my Ubuntu server. It is working, but I can not manage to install MQTT binding. I read many posts, but just can not get it to work. According to this post(MQTT Setup), I should see it in in my PaperUI. But, it is not listed there? I also tried to manually install it by copying the MQTT binding JAR files to my “/usr/share/openhab2/addons” folder, but this causes other errors to appear in log file. Seems like the simplest method should be to use my Paper UI. I can see heaps of other bindings in Paper UI, but seems like all the old v1.xx bindings are not there.

Go to PaperUI -> Configuration -> System and activate “Access Remote Repositories” and “Include Legacy 1.x Bindings” and you should see them all …

Hi, that was one of the first things I did. But, it does not change anything. In PaperUI, when I look at available bindings, nearly all of them are “2.0.0.b5” only. There is only about 8 ones that are “0.9.0.b2”. I had the snapshop version of OH2 installed. I uninstalled it, and installed the Beta 5 version, but exactly the same. I there something I could look for in my configuration files?

I got it to work. My installation package was configured for minimal. After changing it in “addons.cfg”, it now works:
package = standard


OMG… Thank you so much!.. :slight_smile:

This is so helpful. However, I did spend sometime to find the path for “addons.cfg” (duh)! So, I thought of sharing it with any other Noob like me:

These cfg files are created by the openhab account. Any idea how to edit these while they remain owned by the openahb account?

Create a Samba share
and use Visual Studio Code with the openHAB VSC extension to edit your config files.

Thanks so much djhosken. I was about to reinstall the whole thing before I saw this and…problem solved!