[SOLVED] HS-WD200+ Ramp

I just updated to the latest snapshot (openHAB 2.4.0 Build #1441) from 2.3 Stable to gain access to some new devices, but this version changed how my HS-WD200+ switches worked. These are dimmer switchs with a 3 second ramp (by default) so the lights fade on and off. New in 2.4, when openHAB sends a command to change the dimmer percentage to these devices, it appears that it is getting a dimmer value back about half way through the ramp process. Here is an example from the logs.

2018-11-22 17:34:20.928 [ome.event.ItemCommandEvent] - Item 'Dimmer_BasementHall' received command 100
2018-11-22 17:34:20.942 [nt.ItemStatePredictedEvent] - Dimmer_BasementHall predicted to become 100
2018-11-22 17:34:20.959 [vent.ItemStateChangedEvent] - Dimmer_BasementHall changed from 0 to 100
2018-11-22 17:34:22.522 [vent.ItemStateChangedEvent] - Dimmer_BasementHall changed from 100 to 49
2018-11-22 17:37:00.056 [ome.event.ItemCommandEvent] - Item 'Dimmer_BasementHall' received command 0
2018-11-22 17:37:00.103 [nt.ItemStatePredictedEvent] - Dimmer_BasementHall predicted to become 0
2018-11-22 17:37:00.120 [vent.ItemStateChangedEvent] - Dimmer_BasementHall changed from 49 to 0
2018-11-22 17:37:01.684 [vent.ItemStateChangedEvent] - Dimmer_BasementHall changed from 0 to 50
2018-11-22 17:38:00.062 [ome.event.ItemCommandEvent] - Item 'Dimmer_BasementHall' received command 0
2018-11-22 17:38:00.072 [nt.ItemStatePredictedEvent] - Dimmer_BasementHall predicted to become 0
2018-11-22 17:38:00.112 [vent.ItemStateChangedEvent] - Dimmer_BasementHall changed from 50 to 0

Line 2 is new to me in this version, 2.3 never had that line.
Line 3 looks like the switch reported back the goal and started ramping, and it does go to 100% at the switch.
Line 4 is the error. Its a 3 second ramp, and this line is roughly 1.5 seconds after, so it usually reports about half the target value.
Line 5 is the openHAB rule turning the light back off, the light does turn off, to 0, but openHAB reads the value 1.5 seconds later, during the ramp, and thinks the light is still on.
My rule to turn off lights runs every minute, so one minute later openHAB thinks it has to turn the light off still even though it is already off.

Any advice to fix this to the way it functioned in 2.3?

Thanks in advance.

On the device’s Thing, configure the ‘command polling’ to be greater than 3s. Default is 1.5s, which fits to what you are observing. Does your dimmer support the Association command class? If so, you could just disable command polling, since the dimmer will report the level on its own. Command polling is useful for devices that don’t report on their own.

Changing the command pooling did the trick. Thank you. I’m not sure what you are referring to with “Association command class”. Under “Association Groups”, this device just has one item, which is “Lifeline”. Is that it?

Yes, that should do. You could try disabling command polling then, if the controller is in the Lifeline group.

Correction, this is working as expected now, disabled command polling for these switches.