[SOLVED] Http commands for Daikin BRP072A42 WiFi Control working?

I am thinking about getting a Daikin BRP072A42 WiFi Control unit. I can see in some posts that http commands (GET/POST) could be successfully sent to some of these (prior?) WiFi models. Is this still possible for the BRP072A42?

When I asked Daikin directly, they say that communication via http commands is not possible. Instead, they say BACnet would be required.

Any insight is much appreciated.

Hi there - You could just use the OpenHAB Daikin binding. Whilst the documentation on the OpenHAB site does not reflect this compatibility, it works with the BRP072A42 controller. I’ve got them, and they work just fine.

See the following threads for a bit more background information:

And probably best to use the Daikin Binding version containing the fix created by @watou as follows:


Good luck

Many thanks Glen for the very helpful info, and confirmation that it does work. I will read up more on OpenHAB and find out whether/how I can embed it in my VBA based environment. Cheers.

Hi. i’m trying to run the jdaikin binding, but it dosen’t working.
My AC unit has BRP072A42 WiFi Control unit
This is my openhab.cfg:

and this is my item
Switch DaikinPower “Power” { daikin=“sala:power” }

I’ve in my addons directory this version of binding org.openhab.binding.daikin-1.9.0-SNAPSHOT.jar
I’ve downloaded it from this post.

Can someone help me?

Hi there - for the wireless unit the config from my openhab.cfg is as follows:


Note the extra wireless@ bit in there…

Your items definition looks fine.

Good luck

Hi Glen,
unfortunately i’ve already try with this settings…
I re-test the configuration but nothing happend. Unit stay off.
This my openhab.cfg daikin:sala.host=WIRELESS@http://192.168.X.X

I’ve check the unit with http://192.168.X.X/aircon/get_control_info and obtain this result:


How can i drilldown this problem?

Add this line to your logback.xml file, and look at the lines in your openhab.log file:

<logger name="org.openhab.binding.daikin" level="TRACE"/>

Hi. I’ve added that line on my logback.xml, but in my openhab.log file i can find only this line that refer to daikin.

19:59:26.934 [DEBUG] [o.b.d.internal.DaikinActivator:34 ] - Daikin binding has been started.
19:59:27.150 [DEBUG] [i.internal.GenericItemProvider:341 ] - Start processing binding configuration of Item ‘DaikinPower (Type=SwitchItem, State=Uninitialized)’ with ‘DaikinGenericBindingProvider’

Just one quick question - not sure if its relevant, but I kind of had assumed that OH was generally case sensitive. My config file has a lowercase ‘wireless@’ entry, yours above has uppercase… (Unless you were just doing that to emphasise the addition in your post above…).

I updated the advice above to set logging to TRACE level, but looking at the binding source code I don’t think it will show more.

From your openHAB server command line, can you use curl or wget to retrieve a result from http://192.168.X.X/aircon/get_control_info?

My Daikin Altherma split system was finally commissioned yesterday, so now I need to choose between the wired and wireless modules, and then I intend to refactor this binding.

The binding is insensitive to case for WIRELESS and WIRED:

                    if (connectionType.toUpperCase().equals("WIRELESS")) {
                        IDaikin newHost = DaikinFactory.createWirelessDaikin(hostId, host, 0);
                        hosts.put(hostId, newHost);
                    } else if (connectionType.toUpperCase().equals("WIRED")) {
                        IDaikin newHost = DaikinFactory.createWiredDaikin(hostId, host, 0);
                        hosts.put(hostId, newHost);
                    } else {
                        throw new RuntimeException("Unsupported connectionType: " + connectionType);

I’m here again…:pensive:
I set a trace level logging , but the result is like the previous one how already expected from Watou.
Then i try to wget to http://192.168.X.X//aircon/get_control_info. This is the response:


Openhab is installed on an embedded device with a custom version Ubuntu:

uname -mrs show "Linux armv7l"
linux version (user@ubuntu1004desktop) (gcc version 4.4.4 (4.4.4_09.06.2010) ) #88 PREEMPT

Missing Some Component in my distribution ?
What version of Java is required?

If there is an Oracle JDK 1.8 for your OS, I would try that.

Hello i succesfully implemented all command provided. I can turn off and change mode. The only problem i have is to turn on again the AC. I tried to http://192.168.X.X/aircon/set_control_info?pow=1 and it doesn’t work either. Only when all parameter are sent with the pow =1 the AC will turn on.

Hi HABHOME, did you ever solve this? I have the same issue it seems


I had a working version. which stopped when upgraded to 2.2. Now throwing out of index stuff, which I had some time ago.

Do you have a working version of the Daikin binding?